IPB

Welcome Guest ( Log In | Register )

13 Pages V  « < 11 12 13  
Reply to this topicStart new topic
foo_skip: skip tracks that match a specified search query, Was: [Request] Inactive Tracks
EpicForever
post Nov 30 2013, 09:38
Post #301





Group: Members
Posts: 652
Joined: 14-September 11
From: Szczecin, PL
Member No.: 93712



I have to report another unwanted behavior of latest foo_skip version (1.7.8).
My skip pattern is: %keywords% HAS flac OR %keywords% HAS skip OR %rating10% LESS 3 AND NOT %rating10% MISSING
What I did:
I disabled "Skip tracks and use bookmarks" option which is normally turned on. While I listened to the music I enabled it again. Track still played but there was no sound. I am not sure how long it was - I just tried to seek in this track and the sound turned back. I checked tags of this track and it turned out that it has "skip" keyword - which matches my skipping pattern.
So - sound was muted right after I enabled "Skip tracks and use bookmarks" option while playing track that was matching skipping pattern. This is some glitch similar to the one with muted first 16 seconds of manually selected track, that matches skipping pattern.
Go to the top of the page
+Quote Post
EpicForever
post Feb 1 2014, 13:30
Post #302





Group: Members
Posts: 652
Joined: 14-September 11
From: Szczecin, PL
Member No.: 93712



Any news ? smile.gif
Go to the top of the page
+Quote Post
Case
post Feb 2 2014, 13:45
Post #303





Group: Developer (Donating)
Posts: 2137
Joined: 19-October 01
From: Finland
Member No.: 322



Sorry for the delay. The hacky nature of the component has forced some changes to the logic. The component now requires the DSP part and will automatically add it when required. I tried my best to fix the reported bugs for this beta version: removed

Edit: Removed the beta version as stable version is released.

This post has been edited by Case: Feb 23 2014, 14:31
Go to the top of the page
+Quote Post
Jono
post Feb 27 2014, 01:12
Post #304





Group: Members
Posts: 4
Joined: 30-July 13
From: Virginia, USA
Member No.: 109368



For what it is worth, updating from the immediately previous version of this component to the newest has rendered fb2k (v1.3 and 1.3.1) unable to load it...on Windows XP (yeah, yeah, it's my old computer). The code I get is "Unknown Error Code 3221225501". It appears to be working just fine on my W7 machine, though, latest versions and all. Any idea why this might be?
Go to the top of the page
+Quote Post
Case
post Feb 27 2014, 07:59
Post #305





Group: Developer (Donating)
Posts: 2137
Joined: 19-October 01
From: Finland
Member No.: 322



Sorry about that. It was compiled with MSVC 2013, which by default uses SSE2 optimizations unless they are explicitly disabled in the settings. New version uploaded with SSE2 requirements turned off.
Go to the top of the page
+Quote Post
amiti
post Feb 27 2014, 16:34
Post #306





Group: Members
Posts: 152
Joined: 1-January 05
Member No.: 18746



I don't like that this plugin now adds itself to the dsp chain on its own. I liked the plugin but now , if this behavior keeps on I have to stay with the old version.
Go to the top of the page
+Quote Post
Case
post Feb 27 2014, 18:16
Post #307





Group: Developer (Donating)
Posts: 2137
Joined: 19-October 01
From: Finland
Member No.: 322



Using the DSP was always requested as the component's response was otherwise delayed. Unless skipped tracks started with digital silence you could hear them start to play before anything could be done. This won't change back.
Go to the top of the page
+Quote Post
EpicForever
post Mar 3 2014, 17:50
Post #308





Group: Members
Posts: 652
Joined: 14-September 11
From: Szczecin, PL
Member No.: 93712



Seems that something is seriously messed up... I checked my config and I am sure I have DESELECTED checkbox "skip even manually selected tracks" and I have Skip DSP as last (at bottom of list) in my DSP chain. What is happening?
Lets say I got playlist: 20 tracks, first 10 tracks match current skip query (they contain specific KEYWORD tag value).
What I do: I play track 12 and I manually queue track 7. Track 12 ends. Track 7 is skipped (?!) and track 8 plays (??!!!!!). WTF?
Funny thing: if I queue track 7 and 8 one by one, then 7 is skipped and 8 plays fine...
Other messed behaviours:
If I manually start playing from first track then it plays normally till the end - as expected. Then 2nd track is skipped and 3rd played. Sometimes both 2nd and 3rd track are skipped, and 4th is played. When 4th track ends, then 5th or both 5th and 6th track are skipped and next track (6th or 7th - depending on how many tracks were properly skipped) plays normally. I want to remind: first 10 tracks match current skip query...
If I manually start playing from let's say - 3rd track - and while it is played I press "Next" button (from toolbar of from keyboard shortcut) then next track plays fine (????!!!!).

But silent stream bug seems to be [u]eliminated[/u] in every scenario - manually queued track (but this time first queued track is always just skipped), tagging file while it is played (adding keyword that matches skip query while playing), enabling skipping functionality while playing track that matches skip query - none of them causes silent playing until you seek or wait 16-18 seconds.
Go to the top of the page
+Quote Post
LL25255252
post Mar 4 2014, 00:32
Post #309





Group: Members
Posts: 21
Joined: 4-February 13
Member No.: 106410



Hello Case. I'm posting again a suggsstion/request , I've already suggested some months ago (Maybe you forgot about it).
Can you split the "skip even manually selected tracks" to 2 :
  • Skip by Query - even manually selected tracks (T/F) - behaves like the current "skip even manually selected tracks"
  • Skip Parts - even manually selected tracks (T/F) - skips timecodes even on manually selectted tracks.
If you'll split it I will set the first box to FALSE and the second to TRUE.
TIA.
Go to the top of the page
+Quote Post
Case
post Mar 4 2014, 15:51
Post #310





Group: Developer (Donating)
Posts: 2137
Joined: 19-October 01
From: Finland
Member No.: 322



QUOTE (EpicForever @ Mar 3 2014, 18:50) *
Seems that something is seriously messed up...

Version 1.8.2 uploaded that should fix the queue behavior. It now treats all queued tracks as manually selected. But I couldn't see any random behavior like you described, it always just skipped such tracks incorrectly.

QUOTE (LL25255252 @ Mar 4 2014, 01:32) *
Hello Case. I'm posting again a suggsstion/request , I've already suggested some months ago (Maybe you forgot about it).
Can you split the "skip even manually selected tracks" to 2 :
  • Skip by Query - even manually selected tracks (T/F) - behaves like the current "skip even manually selected tracks"
  • Skip Parts - even manually selected tracks (T/F) - skips timecodes even on manually selectted tracks.
If you'll split it I will set the first box to FALSE and the second to TRUE.
TIA.

The logic simplifications I did for v1.8 actually already changed the time code skipping behavior. It's now always in effect unless the component is turned off. The old behavior was broken in my opinion.
Go to the top of the page
+Quote Post
EpicForever
post Mar 4 2014, 16:57
Post #311





Group: Members
Posts: 652
Joined: 14-September 11
From: Szczecin, PL
Member No.: 93712



Hello,
It seems that it is bit more complicated as we both may think. Below there is detailed description what I did and what happened.
I closed foobar, updated component. I opened it. I used autoplaylist with my own ripped CDs to test. I selected one album and tagged it so now files have met skip query. I doubleclicked on 8th track from album and seek to about 10 sec before end. I queued tracks 3,4,5. Everything was fine - track 3 started after track 8. I seeked to nearly the end again, and again. After 5th track finished, 6 track was skipped and then 7th track started playing. So I noted that reported broken behavior persists. I performed few more tests, including playing "normal", untagged files and then queue those tagged to be skipped, to check if queue works fine (if first queued track is not skipped anymore). After some tests I noticed that program stopped skipping only first file after queue finishes and skips all consecutive files that meet skip query. I tried to check it few more times and everything was OK, so I restarted program. Unfortunately after restart everything is broken again and I can do nothing to make it work again.
I only noticed that now ALWAYS only one track is skipped from a row of tracks that meet skip query. So we got a comb: if I play last track before a list of files to be skipped, then foobar plays every even track that meets skip query. If I manually queue or diublecklick first file from such list, then foobar plays every odd track that meets skip query.

My current plugins:

CODE
Core (2013-07-10 12:45:36 UTC)
foobar2000 core 1.2.9
foo_ac3.dll (2012-08-29 16:57:04 UTC)
AC3 decoder 0.9.7
foo_adpcm.dll (2013-08-13 03:01:25 UTC)
kode's ADPCM decoders 1.11
foo_albumlist.dll (2013-02-11 11:28:58 UTC)
Album List 4.5
foo_amipwrapper.dll (2010-01-29 21:32:26 UTC)
AMIP Wrapper 1.01
foo_asap.dll (2014-01-15 21:50:03 UTC)
ASAP 3.1.6
foo_audioscrobbler.dll (2012-11-22 15:41:48 UTC)
Audioscrobbler 1.4.7
foo_beatit.dll (2014-02-19 16:43:02 UTC)
Beat It 0.2
foo_bestversion.dll (2013-03-20 16:00:29 UTC)
Best Version Picker 0.1
foo_bitcompare.dll (2008-12-05 14:08:02 UTC)
Binary Comparator 1.2
foo_cdda.dll (2013-03-07 09:48:32 UTC)
CD Audio Decoder 3.0
foo_converter.dll (2013-07-10 12:25:32 UTC)
Converter 1.5
foo_convolve.dll (2013-03-27 21:18:27 UTC)
Convolver 0.3
foo_deemph.dll (2013-02-08 18:43:34 UTC)
De-emphasis postprocessor 0.0.3
foo_devconsole.dll (2014-02-09 23:19:27 UTC)
DevConsole 1.0.4async
foo_dsp_effect.dll (2013-02-19 19:43:44 UTC)
Effect DSP 0.11
foo_dsp_eq.dll (2013-02-11 11:28:58 UTC)
Equalizer 1.0
foo_dsp_eqsplit.dll (2008-07-13 01:49:10 UTC)
Split equalizer v0.0.1
foo_dsp_fsurround.dll (2012-07-06 22:29:44 UTC)
FreeSurround 0.9.0
foo_dsp_mm.dll (2008-06-06 05:29:12 UTC)
Matrix Mixer 0.3
foo_dsp_resampler.dll (2013-03-27 20:01:33 UTC)
SoX Resampler 0.8.3
foo_dsp_silence.dll (2014-01-27 20:34:20 UTC)
Post-track silence 0.0.4
foo_dsp_std.dll (2013-07-10 12:25:50 UTC)
Standard DSP Array 1.3
foo_dsp_vlevel20080302.0.dll (2008-03-02 22:42:06 UTC)
VLevel 20080302.0
foo_dsp_xfeed.dll (2011-09-19 19:44:30 UTC)
Crossfeed 0.1.3
foo_dsp_xgeq.dll (2012-02-05 12:11:22 UTC)
Graphic Equalizer 0.3.7
foo_dsp_yac.dll (2013-03-27 21:02:35 UTC)
Yet Another Convolver 1.1.0
foo_dumb.dll (2014-02-12 12:00:27 UTC)
DUMB module decoder 1.0.72
foo_dynamicdsp.dll (2012-07-18 06:56:46 UTC)
Dynamic DSP 1.0
foo_fileops.dll (2013-02-11 11:28:10 UTC)
File Operations 2.2
foo_flv.dll (2012-12-29 07:00:00 UTC)
Flash Video Decoder 0.9.6
foo_freedb2.dll (2013-02-11 11:27:56 UTC)
Online Tagger 0.7
foo_gep.dll (2014-02-25 00:51:14 UTC)
Game Emu Player 1.179
foo_hdcd.dll (2012-07-17 19:40:12 UTC)
HDCD decoder 1.15
foo_input_adplug.dll (2013-05-05 17:57:08 UTC)
AdPlug 1.44
foo_input_amr.dll (2009-03-05 20:20:06 UTC)
AMR input 1.1.1
foo_input_celt.dll (2011-05-16 12:21:00 UTC)
CELT Decoder 0.1.2
foo_input_ds.dll (2013-01-20 19:54:37 UTC)
DirectShow input 0.1
foo_input_dsdiff.dll (2011-05-18 19:01:22 UTC)
DSDIFF Decoder 1.4
foo_input_dts.dll (2014-02-16 03:56:42 UTC)
DTS decoder 0.3.3
foo_input_dtshd.dll (2011-03-19 22:41:12 UTC)
DTS-HD Decoder 0.1.3
foo_input_dvda.dll (2012-03-16 16:30:28 UTC)
DVD-Audio Decoder and Watermark Detector 0.4.11
foo_input_exe.dll (2012-10-11 21:56:52 UTC)
Command-Line Decoder Wrapper 0.4
foo_input_gsf.dll (2013-10-21 22:38:43 UTC)
Highly Advanced 2.0.4
foo_input_ht.dll (2013-01-19 15:58:54 UTC)
Highly Theoretical 2.0.37
foo_input_hvl.dll (2013-10-29 18:32:02 UTC)
Hively Tracker decoder 1.14
foo_input_kdm.dll (2012-02-19 10:52:40 UTC)
KDM Decoder 1.1
foo_input_monkey.dll (2013-04-13 10:40:08 UTC)
Monkey's Audio Decoder 2.1.7
foo_input_ncsf.dll (2013-04-26 08:48:42 UTC)
NCSF Decoder 1.7
foo_input_ofr.dll (2011-03-15 22:43:46 UTC)
OptimFROG Lossless/DualStream Decoder 1.31
foo_input_orch.dll (2012-10-29 20:17:30 UTC)
Orch-90 decoder 0.1.5
foo_input_org.dll (2012-02-19 10:53:10 UTC)
Organya decoder 1.9
foo_input_qsf.dll (2012-12-31 17:30:44 UTC)
Highly Quixotic 2.0.25
foo_input_reverse.dll (2009-01-05 19:47:00 UTC)
Reverse Playback 0.1.4 (SSE)
foo_input_sacd.dll (2012-08-25 19:03:10 UTC)
Super Audio CD Decoder 0.5.11
foo_input_shorten.dll (2014-01-03 19:46:18 UTC)
Shorten decoder 0.4.2.3
foo_input_std.dll (2013-07-10 12:45:38 UTC)
Standard Input Array 1.0
foo_input_tak.dll (2013-06-21 10:29:42 UTC)
TAK Decoder 0.4.7
foo_input_tfmx.dll (2012-12-13 15:24:38 UTC)
TFMX decoder 0.10
foo_input_upse.dll (2012-12-22 10:42:24 UTC)
UPSE PSF Decoder 1.8
foo_input_usf.dll (2014-03-02 08:40:00 UTC)
LazyUSF 2.2.8
foo_input_vgmstream.dll (2014-02-26 08:58:55 UTC)
vgmstream plugin r1020-1-geeab20d
foo_input_vio2sf.dll (2014-02-27 00:31:27 UTC)
2SF Decoder 0.24.5
foo_input_zxtune.dll (2013-02-19 21:20:22 UTC)
ZX Tune Player 0.0.1
foo_jesus.dll (2010-09-23 01:34:06 UTC)
Autosave & Autobackup 10
foo_keep_queue.dll (2010-11-12 03:28:46 UTC)
Keep Queue 0.3.5
foo_lnk.dll (2010-01-07 18:57:56 UTC)
Shell Link Resolver 1.3.1
foo_lock.dll (2010-01-11 11:18:36 UTC)
Pause on Lock 0.5
foo_masstag.dll (2013-03-27 21:20:17 UTC)
Masstagger 1.8.4
foo_midi.dll (2013-12-15 05:05:39 UTC)
MIDI synthesizer host 1.229
foo_musical_spectrum.dll (2012-11-21 07:00:00 UTC)
Musical Spectrum 0.9.1
foo_nds.dll (2013-03-22 12:59:18 UTC)
No Display Standby 1.1
foo_osd.dll (2012-12-17 19:28:20 UTC)
On-Screen Display 1.73
foo_out_asio.dll (2012-06-06 13:19:14 UTC)
ASIO support 2.1.2
foo_playcount.dll (2011-07-13 10:47:18 UTC)
Playback Statistics 3.0.2
foo_psf.dll (2013-09-14 20:45:52 UTC)
Highly Experimental 2.0.36
foo_queuecontents.dll (2011-12-31 13:30:56 UTC)
Queue Contents Editor 0.5
foo_rg_trn.dll (2010-01-14 00:01:00 UTC)
ReplayGain override 0.1.3
foo_rgscan.dll (2013-07-10 12:25:36 UTC)
ReplayGain Scanner 2.2
foo_run.dll (2009-06-07 14:15:18 UTC)
Run services 0.3.7
foo_seek.dll (2011-12-20 12:03:06 UTC)
Seek 1.1
foo_seek_box.dll (2010-04-21 14:03:30 UTC)
Seek box 0.0.3
foo_sendtodevice.dll (2013-03-11 17:20:22 UTC)
Send to Device 1.1.2 [Nov 28 2007 - 10:13:31]
foo_sid.dll (2013-04-17 03:49:02 UTC)
sidplay2 1.31
foo_skip.dll (2013-04-13 11:35:16 UTC)
Skip Track 1.7.8 <<<< It's just because I reverted plugin to previous version before I've made a report
foo_snesapu.dll (2013-10-27 07:00:41 UTC)
SNESAPU input 0.80
foo_softplaylists.dll (2013-01-25 19:31:19 UTC)
Soft Playlists 2012-10-10
foo_stop_on_current.dll (2009-06-18 04:54:52 UTC)
Stop on Current 0.4
foo_timebomb.dll (2009-12-20 21:40:00 UTC)
Timebomb 0.0.2
foo_ui_std.dll (2013-07-10 12:45:36 UTC)
Default User Interface 0.9.5
foo_verifier.dll (2013-03-14 11:38:18 UTC)
File Integrity Verifier 1.1.1
foo_vst.dll (2011-03-05 07:19:04 UTC)
VST 2.4 adapter 0.9.0.3
foo_wave_seekbar.dll (2014-02-08 21:37:10 UTC)
Waveform seekbar 0.2.45


Currently I don't use any VST plugins and I use normal DS output. My DSP chain is still the same:
Dynamic DSP
Skip Silence
Matrix Mixer
Downmix multichannel to stereo
Convert mono to stereo
Playback Rate Shift
Skip Track

This post has been edited by EpicForever: Mar 4 2014, 17:06
Go to the top of the page
+Quote Post
Case
post Mar 4 2014, 17:34
Post #312





Group: Developer (Donating)
Posts: 2137
Joined: 19-October 01
From: Finland
Member No.: 322



Could you test without the Dynamic DSP component? It's the one mysterious element causing possible changes to the DSP chain and I'd like to know if removing it helps.
Go to the top of the page
+Quote Post
EpicForever
post Mar 5 2014, 13:16
Post #313





Group: Members
Posts: 652
Joined: 14-September 11
From: Szczecin, PL
Member No.: 93712



OK, I'll try it later but honestly I don't expect change. This component is triggered only when appropiate tags are inside file. I got about 100-120 files that uses this component, and files that I used to test 1.8.1 and 1.8.2 weren't the ones that contain DSP_CHAIN tags.
Go to the top of the page
+Quote Post
Case
post Mar 6 2014, 13:06
Post #314





Group: Developer (Donating)
Posts: 2137
Joined: 19-October 01
From: Finland
Member No.: 322



EpicForever, I could reproduce similar random functionality with foo_playlist_attributes installed. A fixed version is uploaded.
Go to the top of the page
+Quote Post
EpicForever
post Mar 6 2014, 13:43
Post #315





Group: Members
Posts: 652
Joined: 14-September 11
From: Szczecin, PL
Member No.: 93712



Hello again,
Sorry I haven't tested v 1.8.2 without Dynamic DSP... However I already tested v 1.8.3. I noticed only one glitch. Again I have playlist where first 10 tracks matches skipping query. If you disable plugin's functionality from menu, then play track which matches skipping query (let's say 1st) and turn on skipping again, while this track is played back, then 2 situations may happen:
1. next track isn't skipped and plays normally till the end, and after that everything starts working correctly - all tracks from 3 to 10 are skipped
2. next track is skipped, but 3rd track plays normally, and after it ends everything starts working correctly - all tracks from 4 to 10 are skipped
It happens only when track plays normally till the end. If I manually change track (press "Next" button") then everything works fine.

In about 8 testes 2nd scenario happened only once. It is related only to enabling skipping function while track which matches skipping pattern is played. Anyway I think that such situation is so rare that it doesn't need quick fixing if any. Thank you so much for your effort smile.gif

This post has been edited by EpicForever: Mar 6 2014, 13:46
Go to the top of the page
+Quote Post
EpicForever
post Mar 6 2014, 19:23
Post #316





Group: Members
Posts: 652
Joined: 14-September 11
From: Szczecin, PL
Member No.: 93712



It seems that improper closing of foobar also messes... After closing foobar from taskmanager and restarting it misbehaviour of foo_skip seems to be back...
Go to the top of the page
+Quote Post
EpicForever
post Mar 6 2014, 19:47
Post #317





Group: Members
Posts: 652
Joined: 14-September 11
From: Szczecin, PL
Member No.: 93712



Well, after that forced close everything seems to be working permanently incorrectly - again tracks are not skipped, pressing "Next" button doesn't cause track to be skipped. I even tried to get back to 1.7.8, restart, close, put 1.8.3 again and everything is still broken...
Go to the top of the page
+Quote Post
Case
post Mar 7 2014, 12:06
Post #318





Group: Developer (Donating)
Posts: 2137
Joined: 19-October 01
From: Finland
Member No.: 322



I give up. I can not reproduce any problems apart from the slow reaction to being turned on while playing. I have tried adding Dynamic DSP all the other DPSs you use and tested different configurations and as long as the component is enabled skipping works 100% reliably.
Go to the top of the page
+Quote Post
EpicForever
post Mar 7 2014, 13:47
Post #319





Group: Members
Posts: 652
Joined: 14-September 11
From: Szczecin, PL
Member No.: 93712



OK, so I will try to perform investigation on my own, but I can't declare any deadline when it will be finished.
Go to the top of the page
+Quote Post
-AdZero-
post Mar 8 2014, 23:17
Post #320





Group: Members
Posts: 20
Joined: 17-September 08
From: France
Member No.: 58361



Hi !

foo_skip is not anymore in the official foobar2000 plugin repository ?
I saw an update a few days ago but now it isn't even listed.

Any idea ?

Thanks.
Go to the top of the page
+Quote Post
Hazey
post Apr 9 2014, 17:43
Post #321





Group: Members
Posts: 7
Joined: 26-March 11
Member No.: 89327



I've also noticed that it's gone! I hope it's coming back. I just did a reinstall of foobar and deleted my plugins, thinking I could just download them again. I had no problems with foo_skip fwiw, I really hope it comes back.

This post has been edited by Hazey: Apr 9 2014, 17:51
Go to the top of the page
+Quote Post
Case
post Yesterday, 10:54
Post #322





Group: Developer (Donating)
Posts: 2137
Joined: 19-October 01
From: Finland
Member No.: 322



New version uploaded.
Go to the top of the page
+Quote Post

13 Pages V  « < 11 12 13
Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st April 2014 - 03:46