IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
Difference in sound quality between generic MS "HD Audio" Wi
davidh44
post Jul 9 2012, 19:06
Post #1





Group: Members
Posts: 6
Joined: 11-July 03
Member No.: 7721



If leaving all settings at default and assuming 2 speaker setup, is there any difference in sound quality between using the generic "High Definition Audio Device" driver included with Windows 7 vs. installing the Realtek (or other manufacturer's) HDaudio driver?
Go to the top of the page
+Quote Post
benski
post Jul 9 2012, 19:44
Post #2


Winamp Developer


Group: Developer
Posts: 669
Joined: 17-July 05
From: Ashburn, VA
Member No.: 23375



Most likely, no. There are two possible areas of differences.
First, the resampling might work differently. Many sound cards only run at a single frequency (48kHz or 96kHz) and all audio is resampled. Windows 7 fixed a lot of the quirkiness, but on older systems it could vary based on the driver. Some drivers will "lie" and say they support 44.1khz and then resample themselves. Others will tell the OS they only support 96kHz and let the OS resample. I once had an external Sound Blaster whose resampling was so bad that I could easily ABX it (discovered when successfully ABX'ing 44.1kHz vs 96kHz, only to fail miserably later when going from 96->44.1->96 cleanly in software). Again, this is unlikely to be an issue in Windows 7, but was a major source of problems in Windows XP and prior.
Second, the mapping between windows volume and analog volume on the line-out might differ. Sometimes "50" is 0-gain, sometimes "67", sometimes "100". And it can vary amongst drivers. This can cause audible differences due to level-matching issues as well as potential analog distortion from overdriving the output. But this is an analog issue (and easily compensated for) and not an issue with the driver per se.

This post has been edited by benski: Jul 9 2012, 19:46
Go to the top of the page
+Quote Post
davidh44
post Jul 10 2012, 03:29
Post #3





Group: Members
Posts: 6
Joined: 11-July 03
Member No.: 7721



QUOTE (benski @ Jul 9 2012, 11:44) *
Most likely, no. There are two possible areas of differences.
First, the resampling might work differently. Many sound cards only run at a single frequency (48kHz or 96kHz) and all audio is resampled. Windows 7 fixed a lot of the quirkiness, but on older systems it could vary based on the driver. Some drivers will "lie" and say they support 44.1khz and then resample themselves. Others will tell the OS they only support 96kHz and let the OS resample. I once had an external Sound Blaster whose resampling was so bad that I could easily ABX it (discovered when successfully ABX'ing 44.1kHz vs 96kHz, only to fail miserably later when going from 96->44.1->96 cleanly in software). Again, this is unlikely to be an issue in Windows 7, but was a major source of problems in Windows XP and prior.
Second, the mapping between windows volume and analog volume on the line-out might differ. Sometimes "50" is 0-gain, sometimes "67", sometimes "100". And it can vary amongst drivers. This can cause audible differences due to level-matching issues as well as potential analog distortion from overdriving the output. But this is an analog issue (and easily compensated for) and not an issue with the driver per se.

Oh wow ohmy.gif , I got a reply from a WinAMP developer! I love my WinAMP + Enhancer DSP plugin.

Thanks for the explanation. smile.gif
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st April 2014 - 12:01