IPB

Welcome Guest ( Log In | Register )

> foobar2000 General Forum Rules

This is NOT a tech support forum.
Tech support questions go to foobar2000 Tech Support forum instead.

See also: Hydrogenaudio Terms of Service.

14 Pages V  « < 2 3 4 5 6 > »   
Reply to this topicStart new topic
Playback Statistics component: version 3.0.1, Discussion, feedback and beta versions
mystNZ
post Aug 26 2010, 20:30
Post #76





Group: Members
Posts: 44
Joined: 13-February 08
Member No.: 51283



QUOTE (tpijag @ Aug 27 2010, 06:14) *
Added date = date added to library. Static.
It is not intended to be editable.

terry

I realize that, but unfortunately something happened to several of the songs in my library - they had their added (and first played) data reset (I suspect by foo_dop somehow during a synchronization, but am not certain). Now, for example, I have songs that have been released (and actually added) in 2008 with "last played" in 2010 but "added" and "first played" in 2001 ..... also, if the added date is not intended to be editable, then why is there a "Added time" selection box in the import from XML dialog? .....
Go to the top of the page
+Quote Post
muzack
post Aug 26 2010, 21:42
Post #77





Group: Members
Posts: 113
Joined: 14-December 08
Member No.: 64497



You can edit the added date in playbackstat this way:

write an id3 tag called "added" into your file with the date you wish, in format YYYY-MM-DD HH:MM:SS (something like 2008-08-30 11:05:00).
Then apply/save the new tag, go to tracks contexmenu>Playbackstatistics>Import statistics from file tags.
Voila got you added date edited.
This works for all date fields! (and rating)
Keep in mind: if your playback statistic hold an earlier date than you want to add, then it doesn't work!
at example: playbackstat %added% is 2001-10-30 12:00:00 then you can't import a later date like 2009-10-30 12:00:00.
In this case you have to reset(?) the statistics for the selected file (didn't try the latter).
That's the way it should work.
Go to the top of the page
+Quote Post
Zulithe
post Aug 27 2010, 06:24
Post #78





Group: Members
Posts: 46
Joined: 20-December 02
Member No.: 4171



Is there any way to use this component WITHOUT it EVER modifying the actual audio files themselves? Because explorer is telling me they are being modified after a song finishes (the 'date modified' date changes).

I do not want foobar2000 to modify the actual audio files ever... unless I do so manually (like editing id3 tags to correct a mistake)

Is there no way to disable this?

*edit* okay I just removed this component and it is still happening... trying to get to the bottom of it. so annoying :/

This post has been edited by Zulithe: Aug 27 2010, 06:30
Go to the top of the page
+Quote Post
shakey_snake
post Aug 27 2010, 06:31
Post #79





Group: FB2K Moderator
Posts: 4322
Joined: 1-November 06
From: Cincinnati
Member No.: 37036



It does not modify files by default--you'll need to go into advanced preferences and uncheck the setting that you, at some point, turned on.

This post has been edited by shakey_snake: Aug 27 2010, 06:32


--------------------
elevatorladylevitateme
Go to the top of the page
+Quote Post
GeSomeone
post Aug 27 2010, 11:58
Post #80





Group: Members
Posts: 920
Joined: 22-October 01
From: the Netherlands
Member No.: 335



QUOTE (mystNZ @ Aug 26 2010, 21:30) *
[..]unfortunately something happened to several of the songs in my library - they had their added (and first played) data reset

The same thing happened to me, the added field was gone, only for one or two (in my case recent) albums that were in the library. I tried a couple of things to get the added filed back (like rescan library now). If I recall correctly a new added field appeared when I switched "monitor playing tracks" on/off.
The tracks that had already been played now have an "played" time before the "added" time.

I have not filed a bug report cause I haven't found out how to reproduce.


--------------------
In theory, there is no difference between theory and practice.
Go to the top of the page
+Quote Post
kruji
post Aug 28 2010, 12:24
Post #81





Group: Members
Posts: 19
Joined: 27-February 08
Member No.: 51641



QUOTE (Yirkha @ Jul 24 2010, 18:58) *
  - <your-foobar2000-profile>\index-data\6370B286-BE93-4A7C-AA3B-281FEC61B182


is ist possible to customize the path of the database? e.g. user-components\foo_playcount?

thanks in advance.

This post has been edited by kruji: Aug 28 2010, 12:24
Go to the top of the page
+Quote Post
rend3r
post Aug 30 2010, 01:27
Post #82





Group: Members
Posts: 3
Joined: 20-May 10
Member No.: 80773



Do I have any chance to get latest foo_playcount for 1.0.x branch?
Go to the top of the page
+Quote Post
Yirkha
post Aug 30 2010, 12:19
Post #83





Group: FB2K Moderator
Posts: 2359
Joined: 30-November 07
Member No.: 49158



QUOTE (kruji @ Aug 28 2010, 13:24) *
is ist possible to customize the path of the database? e.g. user-components\foo_playcount?
The database is managed by foobar2000 core, not foo_playcount. Therefore it is stored in a component-independent directory too.


--------------------
Full-quoting makes you scroll past the same junk over and over.
Go to the top of the page
+Quote Post
Jubei
post Sep 1 2010, 19:19
Post #84





Group: Members
Posts: 76
Joined: 13-July 04
From: Hong Kong
Member No.: 15410



Ok. Read this thread several times, but am getting confused.

My problem = last played and rating won't display in the playlist view but appears ok in properties dialog box. As far as I can see in properties dialog box, the playback stats are updated. Does this mean data is update in tag or in the database? Or both?

How can I get last played and ratings to display within playlist view? The data displays fine in the Item Details panel. What I done so far is in the Preferences > Columns UI > Playlist View > Columns > Column Details Scripts tab ... have tried => rating (didn't display anything) / %rating% (didn't display anything) / $meta(rating) (didn't display anything) / "$meta(rating)" (didn't display anything).

What should I do now? Really need some help.

By the way, this problem only appeared after I upgraded to Foobar v1.1 last night. Everything was perfectly fine in v0.9.6.9.

Thanks!
Go to the top of the page
+Quote Post
Robertina
post Sep 1 2010, 21:17
Post #85





Group: Members
Posts: 1215
Joined: 4-January 09
Member No.: 65169



QUOTE (Jubei @ Sep 1 2010, 07:19) *
What should I do now? Really need some help.

While %rating% and %last_played% fetches that information from the file <your-foobar2000-profile>\index-data\6370B286-BE93-4A7C-AA3B-281FEC61B182 (see Yirkha's post here), $meta(rating)/$meta(last_played) fetches that information from your audio files. If you have saved that information in your files you can import it. As long as you don't change the default setting in File, Preferences, Advanced, Tools, Playback Statistics -> Automatically synchronize file tags with statistics (default = unticked), there is nothing written automatically to your files.

Playback Statistics versions prior to v3.0 save their data in a file named PlaybackStatistics.dat (saved in foobar's program folder for foobar versions prior to 1.1) which should be deleted automatically when updating to v3.0.

When upgrading to foobar v1.1 you are asked whether your components which don't come with foobar's installer itself should be kept in their current folder or be moved to your user-components folder (each component would have its own sub folder then). I don't know which decision you have made and also I am no expert but you could check whether the PlaybackStatistics.dat has been deleted as it should be.

Also you can press shift + [main menu] file -> Browse configuration folder to see where your foo_playcount should be located.

I hope that helps a little bit.
Go to the top of the page
+Quote Post
Jubei
post Sep 1 2010, 21:34
Post #86





Group: Members
Posts: 76
Joined: 13-July 04
From: Hong Kong
Member No.: 15410



Thanks first for the info.

I normally have Foobar installed in portable mode and unfortunately I installed components the old fashioned way by dropping the dll files into the components folder sad.gif

The PlaybackStatistic.dat => I coped that to the new folder for Foobar v1.1. The data was loaded and the file was automatically deleted.

In the Index-data folder I now have a file named C653739F-14B3-4EF2-819B-A3E2883230AE ... is this the new Playback Statistics database file? I'm assuming the file name you quote (6370B286-BE93-4A7C-AA3B-281FEC61B182) is generated dynamically and the name varies.

Still, inserting %rating% in my columns ui > playlist view config doesn't seem to display any ratings data sad.gif Since for the Item Details panel I use %rating% I assume that the component is working as new data is being stored and displayed. And I do have the automatically sync file tags with statistics unticked, because many versions ago it occasionally caused crashes. I just can't seem to get the data to be displayed in playlist view ...



QUOTE (Robertina @ Sep 2 2010, 04:17) *
QUOTE (Jubei @ Sep 1 2010, 07:19) *
What should I do now? Really need some help.

While %rating% and %last_played% fetches that information from the file <your-foobar2000-profile>\index-data\6370B286-BE93-4A7C-AA3B-281FEC61B182 (see Yirkha's post here), $meta(rating)/$meta(last_played) fetches that information from your audio files. If you have saved that information in your files you can import it. As long as you don't change the default setting in File, Preferences, Advanced, Tools, Playback Statistics -> Automatically synchronize file tags with statistics (default = unticked), there is nothing written automatically to your files.

Playback Statistics versions prior to v3.0 save their data in a file named PlaybackStatistics.dat (saved in foobar's program folder for foobar versions prior to 1.1) which should be deleted automatically when updating to v3.0.

When upgrading to foobar v1.1 you are asked whether your components which don't come with foobar's installer itself should be kept in their current folder or be moved to your user-components folder (each component would have its own sub folder then). I don't know which decision you have made and also I am no expert but you could check whether the PlaybackStatistics.dat has been deleted as it should be.

Also you can press shift + [main menu] file -> Browse configuration folder to see where your foo_playcount should be located.

I hope that helps a little bit.

Go to the top of the page
+Quote Post
Yirkha
post Sep 1 2010, 21:40
Post #87





Group: FB2K Moderator
Posts: 2359
Joined: 30-November 07
Member No.: 49158



QUOTE (Jubei @ Sep 1 2010, 22:34) *
In the Index-data folder I now have a file named C653739F-14B3-4EF2-819B-A3E2883230AE ... is this the new Playback Statistics database file? I'm assuming the file name you quote (6370B286-BE93-4A7C-AA3B-281FEC61B182) is generated dynamically and the name varies.
Actually, the Playback Statistics component has been updated since I wrote that (during 3.0 beta release), so I assume the changed internal format resulted in a new index data ID too. I think there are one-way internal importers for the older formats, so if someone updates from e.g. 3.0 beta 1 to 3.0 final, the statistics are not lost. Anyway, the file name should stay the same a while now.


--------------------
Full-quoting makes you scroll past the same junk over and over.
Go to the top of the page
+Quote Post
Jubei
post Sep 1 2010, 21:46
Post #88





Group: Members
Posts: 76
Joined: 13-July 04
From: Hong Kong
Member No.: 15410



... so how can I check if the Playback Statistics component is either creating a database or whether the file I have is the database? As I noted, the properties dialog box of tracks does show changes in play count, rating and last played, but I just want to make sure it is writing to database and not tags (although auto sync to file tags is disabled).

By the way, that is the only file I have in the Index-data folder, and I can find no other file that looks similar (i.e. a long chain of numbers) within my Foobar folder (which since I have it installed as portable, everything should be in it).

This post has been edited by Jubei: Sep 1 2010, 21:49
Go to the top of the page
+Quote Post
Robertina
post Sep 1 2010, 22:14
Post #89





Group: Members
Posts: 1215
Joined: 4-January 09
Member No.: 65169



You can install as many foobar versions as you want in portable mode. So may I suggest to install f2k 1.1 in portable mode to another folder, then go to Preferences, Components and choose the install button to install Playback Statistics v2.1.9 (if you don't have it anymore I can upload it). Close foobar and copy your PlaybackStatistics.dat into foobar's root folder. Run foobar again and see whether your rating and last played columns show any content now.

Then install foo_playcount v3.0 the same way and watch your installation folder to learn how this index-data file is created and where. Then you should be able to apply your knowledge to your original portable installation.
Go to the top of the page
+Quote Post
Jubei
post Sep 1 2010, 22:19
Post #90





Group: Members
Posts: 76
Joined: 13-July 04
From: Hong Kong
Member No.: 15410



Good idea!

To be frank, though, I think my problem is less with Playback Statistics now ... and much more to do with my inability to get Playlist View under Columns UI to display what I want to see. I tried the Tools button in the Playlist View tab to preview the script and the preview actually did show the data ... so the %rating% and %last_played% did show data in the preview. For some reason it just won't show in the playlist view proper!

QUOTE (Robertina @ Sep 2 2010, 05:14) *
You can install as many foobar versions as you want in portable mode. So may I suggest to install f2k 1.1 in portable mode to another folder, then go to Preferences, Components and choose the install button to install Playback Statistics v2.1.9 (if you don't have it anymore I can upload it). Close foobar and copy your PlaybackStatistics.dat into foobar's root folder. Run foobar again and see whether your rating and last played columns show any content now.

Then install foo_playcount v3.0 the same way and watch your installation folder to learn how this index-data file is created and where. Then you should be able to apply your knowledge to your original portable installation.


This post has been edited by Jubei: Sep 1 2010, 22:22
Go to the top of the page
+Quote Post
Robertina
post Sep 1 2010, 22:28
Post #91





Group: Members
Posts: 1215
Joined: 4-January 09
Member No.: 65169



This is really strange. I can tell you that both %rating% and %last_played% works for me. What happens if you use that patterns as scripts in Columns UI, then close foobar and restart it? Sometimes this is necessary, I don't know why but it happened with other scripts here too. Maybe it has something to do how the columns are updated.

I am sorry that I couldn't be of greater help (sorry for English).

This post has been edited by Robertina: Sep 1 2010, 22:29
Go to the top of the page
+Quote Post
Jubei
post Sep 1 2010, 22:31
Post #92





Group: Members
Posts: 76
Joined: 13-July 04
From: Hong Kong
Member No.: 15410



OH MY GOD! RESET SOLVED EVERYTHING!!

MANY THANKS!!


QUOTE (Robertina @ Sep 2 2010, 05:28) *
This is really strange. I can tell you that both %rating% and %last_played% works for me. What happens if you use that patterns as scripts in Columns UI, then close foobar and restart it? Sometimes this is necessary, I don't know why but it happened with other scripts here too. Maybe it has something to do how the columns are updated.

I am sorry that I couldn't be of greater help (sorry for English).

Go to the top of the page
+Quote Post
Robertina
post Sep 1 2010, 22:54
Post #93





Group: Members
Posts: 1215
Joined: 4-January 09
Member No.: 65169



I am very glad that you have been able to solve the problem.

Robertina.
Go to the top of the page
+Quote Post
thi3nki3p
post Sep 6 2010, 11:51
Post #94





Group: Members
Posts: 14
Joined: 26-August 10
Member No.: 83385



Hello, recently I'm starting to listen to shoutcast radio using foobar.
Since "collection of playback statistics is no longer restricted to your Media Library content" and I have the option "automatically synchronize file tags" on, hence after 1 min playback foobar causes an error trying to write file tags and stops the streaming.
Is there any sane way to avoid this? If not, it would be nice to have workaround in the next release.
Go to the top of the page
+Quote Post
lrossouw
post Sep 6 2010, 20:14
Post #95





Group: Members
Posts: 8
Joined: 23-August 09
From: Singapore
Member No.: 72561



I'd like to be able to create an xml restore file that would update the statistics in this tool. How would I need to create entry id, mapping, time and rating fields. Is the entry ID some sort of hash of the artist\album\track that is reproducable?
Go to the top of the page
+Quote Post
copperblue
post Sep 8 2010, 09:33
Post #96





Group: Members
Posts: 39
Joined: 20-August 06
Member No.: 34244



QUOTE (Canar @ Aug 16 2010, 23:42) *
Bug report: I have two albums with the same artist and title but different track listings. However, statistics component does not differentiate the two. See:



The first visible column to the right of "Track Information" is the the play counter.

I've duplicated this bug.
Using an album ripped to mp3 VBR V0 with various play_count and rating, I reripped from the original CD into ALAC (using dbpoweramp) and dropped the m4a files into the same folder as the mp3 files.
Foobar associated the play counts and ratings with the new m4a files also...

This is really handy as I rerip my collection one last time into lossless (finally), but also has the potential to confuse biggrin.gif

This post has been edited by copperblue: Sep 8 2010, 09:41
Go to the top of the page
+Quote Post
shakey_snake
post Sep 8 2010, 14:57
Post #97





Group: FB2K Moderator
Posts: 4322
Joined: 1-November 06
From: Cincinnati
Member No.: 37036



QUOTE (copperblue @ Sep 8 2010, 04:33) *
QUOTE (Canar @ Aug 16 2010, 23:42) *
Bug report: I have two albums with the same artist and title but different track listings. However, statistics component does not differentiate the two.

I've duplicated this bug.
Using an album ripped to mp3 VBR V0 with various play_count and rating, I reripped from the original CD into ALAC (using dbpoweramp) and dropped the m4a files into the same folder as the mp3 files.
Foobar associated the play counts and ratings with the new m4a files also...
You do not have the same bug. Canar has two albums, you have multiple copies of one album.

Your case is an example of the intended behavior. It is a different behavior than previous versions, but it is intended.


--------------------
elevatorladylevitateme
Go to the top of the page
+Quote Post
Copland
post Sep 8 2010, 20:32
Post #98





Group: Members
Posts: 29
Joined: 16-September 07
Member No.: 47106



My ML is stored on a NAS. I use an identical foobar config on two computer systems, one of which is connected to the nas via LAN, the other via WLAN. Strangely enough, the "ADDED" values seem to be treated different on the two computers. One of them - the WLAN one - ignores changes of existing files (esp. Tagging) and keeps the original date of adding the files to the ML. The LAN-connected system, however, treats every change to an already existing file added to the ML long ago as a new adding event, thus changing the ADDED value to the actual date. I cannot explain this behaviour - can anyone else? Maybe some odd setting that's different on the systems?

Go to the top of the page
+Quote Post
Yirkha
post Sep 8 2010, 23:30
Post #99





Group: FB2K Moderator
Posts: 2359
Joined: 30-November 07
Member No.: 49158



Do the computers run different OS?


--------------------
Full-quoting makes you scroll past the same junk over and over.
Go to the top of the page
+Quote Post
Copland
post Sep 9 2010, 09:28
Post #100





Group: Members
Posts: 29
Joined: 16-September 07
Member No.: 47106



QUOTE (Yirkha @ Sep 8 2010, 23:30) *
Do the computers run different OS?


No, both are running on xp home sp3! Do you agree that changing tags using one computer should not lead to changing the ADDED value on the other computer?

This post has been edited by Copland: Sep 9 2010, 10:02
Go to the top of the page
+Quote Post

14 Pages V  « < 2 3 4 5 6 > » 
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 18th April 2014 - 07:58