IPB

Welcome Guest ( Log In | Register )

> foobar2000 Tech Support Forum Rules

Please read foobar2000 Tech Support Forum Rules before posting and comply with all the points.
Failure to provide all the information pointed out in the above document in your post is considered wasting other people's time and in extreme cases will lead to your topic getting locked without a reply.


See also: Hydrogenaudio Terms of Service.

 
Reply to this topicStart new topic
Windows 8 trouble with opening music files in Explorer
remm
post Nov 10 2012, 05:52
Post #1





Group: Members
Posts: 3
Joined: 10-November 12
Member No.: 104424




The problem started when I 'upgraded' to Windows 8.

Here's what it looks like.
If I double click on a music file in windows Explorer, nothing will happen.
If I right click on a music file, and go Open With, and select foobar2000, the music will play.

This happens for all file types that foobar is associated with. If I associate .mp3 with another music player, I have no trouble opening it.
It makes no difference whether or not foobar is already open at the time.
I have tried reinstalling 1.1.16 and changing the file type associations around, but it fixed nothing.
I also tried installing an older version 1.1.5 I found I had saved (which I knew had worked for me), and it fixed nothing. (meaning that Windows 8 is the problem)

Any help or suggestions would be appreciated.
Go to the top of the page
+Quote Post
Case
post Nov 11 2012, 11:10
Post #2





Group: Developer (Donating)
Posts: 2136
Joined: 19-October 01
From: Finland
Member No.: 322



Is this normal installation and not a portable install? If it's normal installation, open Default Programs -> Set your default programs, select Windows Media Player and click on the "Set this program as default" to associate common formats away from foobar. Then select foobar2000 from the list at left and associate formats you want back to it.
If it's a portable install and you associate files manually, it could be that Windows has stored wrong path for the exe in the registry. That can be fixed by removing HKEY_CLASSES_ROOT\Applications\foobar2000.exe key.
Go to the top of the page
+Quote Post
remm
post Nov 11 2012, 11:31
Post #3





Group: Members
Posts: 3
Joined: 10-November 12
Member No.: 104424



Thanks for your reply

This is a normal install. The only extensions I added are Columns UI and Foobar2000 Advanced Controls.
I followed your steps to associate the file formats to Windows Media Player, and I was able to open music normally with that as the default. When I associated .mp3 back to foobar, the problem still exists. The first time I try to open the music with foobar as the default (double clicking on the file on my desktop), the computer thinks for a second (pointer changes to indicate it's working), and then it stops. Any further attempts to open a music file do nothing at all.
Go to the top of the page
+Quote Post
Case
post Nov 11 2012, 11:43
Post #4





Group: Developer (Donating)
Posts: 2136
Joined: 19-October 01
From: Finland
Member No.: 322



I can replicate your problem if I edit foobar2000 compatibility settings and make it run as administrator. If you aren't doing silly things like this, download Process Monitor and create a log of what happens on double click.
Go to the top of the page
+Quote Post
remm
post Nov 12 2012, 06:06
Post #5





Group: Members
Posts: 3
Joined: 10-November 12
Member No.: 104424



Something silly like running it as an administrator. Yes, for some reason it was set to do that. I am sure I didn't change that setting recently, but it might have copied over when I upgraded to 8.

Thanks for your help!
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 18th April 2014 - 10:30