IPB

Welcome Guest ( Log In | Register )

101 Pages V  « < 97 98 99 100 101 >  
Reply to this topicStart new topic
Album Art Downloader XUI, A tool for downloading cover art
AlexVallat
post Dec 21 2013, 09:08
Post #2451





Group: Developer
Posts: 1048
Joined: 31-July 06
Member No.: 33465



QUOTE (Eli @ Dec 20 2013, 20:53) *
Also, any reason the code does not seem to ignore (Disc X)?
If you mean literally an "X" then it's because the regex is set to look for numbers (\d+ means any digits). You could replace "\d+" with "(\d+|X)" which means any digits, or a single X.

Alex
Go to the top of the page
+Quote Post
Eli
post Dec 21 2013, 13:26
Post #2452





Group: Members
Posts: 1055
Joined: 16-October 03
Member No.: 9337



no I mean "x" as in 1,2,3...(digits). For some reason, I am still getting (Disc 1)... in my searches


--------------------
http://forum.dbpoweramp.com/showthread.php?t=21072
Go to the top of the page
+Quote Post
AlexVallat
post Dec 21 2013, 14:00
Post #2453





Group: Developer
Posts: 1048
Joined: 31-July 06
Member No.: 33465



QUOTE (Eli @ Dec 21 2013, 13:26) *
no I mean "x" as in 1,2,3...(digits). For some reason, I am still getting (Disc 1)... in my searches
Send me a PM with an example of a full path that isn't being ignored properly, and the current matching path pattern you are using, and I'll take a look.

Alex
Go to the top of the page
+Quote Post
Pjosip
post Dec 29 2013, 18:13
Post #2454





Group: Members
Posts: 1
Joined: 29-December 13
Member No.: 113628



Hey, I was reading trough first 6 pages and don't really have the time to read trough all 99 of them to see if somebody had the same issue as I do.

So my music is located in Libraries\Music (the standard location) and majority of it (over 150 songs) is unorganized on 1 folder with couple of them being in separate folders.
When I used file browser it shows as if all songs already have covers, but in reality most of them (about 90%) eather don't work, or are consistent of low-quallity image that is almost unreadable.

Now what I wish to do is to replace art for all existing covers.

So I select everything and click "Get artwork for selection" but when I try to download the art that I like and click "Overwrite the existing file with the new one" I get an error saying "Could not save image 'C:\Users\Josip\Music\Folder.jpg': Acces to the path 'C:\Users\Josip\Music\Folder.jpg' is denied.

I have tried with a different folder on local disc D and unckecking "read only" and also when I try to search for it (with option show hidden files and folders on) it does not exist.

And if I try the 2nd option "Save the new file as Folder(2).jpg" and open the song it (again) does not show apropriate album art.

I realize I am most probably doing something wrong so any help would be nice.
I am mostly trying to download proper (HQ) album art for my phone and will try to download lyrics later.

With kind regards
-Josip Pejčinović
Go to the top of the page
+Quote Post
AlexVallat
post Dec 29 2013, 21:34
Post #2455





Group: Developer
Posts: 1048
Joined: 31-July 06
Member No.: 33465



QUOTE (Pjosip @ Dec 29 2013, 18:13) *
So my music is located in Libraries\Music (the standard location) and majority of it (over 150 songs) is unorganized on 1 folder with couple of them being in separate folders.

Hi, if all your albums are are in the same folder, then you need to define where to save the cover art files. The default of "Folder.jpg" in the same folder as the album clearly isn't going to work, as you can only have one file called "Folder.jpg" in the folder which has your music in it.

You could, for example, set the path to find images to be "C:\Users\Josip\Pictures\Album Art\%artist%\%album%.%extension%".

I don't know how your phone locates album art, though. Almost everything supports Folder.jpg in the same folder as the album, but if your phone supports some way of looking up the art files when there are multiple albums in the same folder, you will have to find out what it is.

If the phone require the art to be embedded inside the music file itself, then you will need library management software to take the art files downloaded by Album Art Downloader and go through all the music in your library and embed the correct file in each music file. I believe Mp3Tag can do this sort of thing.

Alex
Go to the top of the page
+Quote Post
ChrisCTR
post Jan 15 2014, 16:45
Post #2456





Group: Members
Posts: 4
Joined: 15-January 14
Member No.: 114031



There's a bad flaw at times when I click on an album art result. Say, if there's an album art result that shows 300x300 and I click on it. It turns into a much less quality image. The 300x300 would turn into something, like a 130x130, for example. Can this be fixed?
Go to the top of the page
+Quote Post
AlexVallat
post Jan 15 2014, 19:52
Post #2457





Group: Developer
Posts: 1048
Joined: 31-July 06
Member No.: 33465



QUOTE (ChrisCTR @ Jan 15 2014, 16:45) *
There's a bad flaw at times when I click on an album art result. Say, if there's an album art result that shows 300x300 and I click on it. It turns into a much less quality image. The 300x300 would turn into something, like a 130x130, for example. Can this be fixed?

Could you let me know which source, (and which album you searched for, if it only happens with a specific album) and I'll look into it.

Alex
Go to the top of the page
+Quote Post
ChrisCTR
post Jan 15 2014, 20:54
Post #2458





Group: Members
Posts: 4
Joined: 15-January 14
Member No.: 114031



QUOTE (AlexVallat @ Jan 15 2014, 13:52) *
QUOTE (ChrisCTR @ Jan 15 2014, 16:45) *
There's a bad flaw at times when I click on an album art result. Say, if there's an album art result that shows 300x300 and I click on it. It turns into a much less quality image. The 300x300 would turn into something, like a 130x130, for example. Can this be fixed?

Could you let me know which source, (and which album you searched for, if it only happens with a specific album) and I'll look into it.

Alex


Do an artist search for Tony Guerrero, and the album name "Now and Then". There is a displayed 300x300 album art image. When I click on it, it changes on the screen into a 130x130 image and is saved that way. If I kept giving you many results like this, it would be an ongoing issue and the list would be too numerous and lengthy to report more similar issues like this one.
Go to the top of the page
+Quote Post
ChrisCTR
post Jan 16 2014, 01:54
Post #2459





Group: Members
Posts: 4
Joined: 15-January 14
Member No.: 114031



QUOTE (ChrisCTR @ Jan 15 2014, 14:54) *
QUOTE (AlexVallat @ Jan 15 2014, 13:52) *
QUOTE (ChrisCTR @ Jan 15 2014, 16:45) *
There's a bad flaw at times when I click on an album art result. Say, if there's an album art result that shows 300x300 and I click on it. It turns into a much less quality image. The 300x300 would turn into something, like a 130x130, for example. Can this be fixed?

Could you let me know which source, (and which album you searched for, if it only happens with a specific album) and I'll look into it.

Alex


Do an artist search for Tony Guerrero, and the album name "Now and Then". There is a displayed 300x300 album art image. When I click on it, it changes on the screen into a 130x130 image and is saved that way. If I kept giving you many results like this, it would be an ongoing issue and the list would be too numerous and lengthy to report more similar issues like this one. The image you are looking for is violet, yellow and green in color. There's a large green "G" in the album art.

Go to the top of the page
+Quote Post
AlexVallat
post Jan 16 2014, 09:03
Post #2460





Group: Developer
Posts: 1048
Joined: 31-July 06
Member No.: 33465



QUOTE (ChrisCTR @ Jan 15 2014, 20:54) *
Do an artist search for Tony Guerrero, and the album name "Now and Then".

Thanks, but what I need to know is which source you are using - for example Google Images, or Amazon, or iTunes, etc. These scripts regularly break as the websites are changed, and I rely on people reporting when they don't work so I can fix them up with whatever changes have been made, or discontinue them if the website itself no longer works.

Alex
Go to the top of the page
+Quote Post
ChrisCTR
post Jan 16 2014, 15:51
Post #2461





Group: Members
Posts: 4
Joined: 15-January 14
Member No.: 114031



QUOTE (AlexVallat @ Jan 16 2014, 03:03) *
QUOTE (ChrisCTR @ Jan 15 2014, 20:54) *
Do an artist search for Tony Guerrero, and the album name "Now and Then".

Thanks, but what I need to know is which source you are using - for example Google Images, or Amazon, or iTunes, etc. These scripts regularly break as the websites are changed, and I rely on people reporting when they don't work so I can fix them up with whatever changes have been made, or discontinue them if the website itself no longer works.

Alex

I normally have ALL sources checked when I use the Album Art Downloader XUI program. Anyway I tried again and it is using an album cover result from LastFM.
Go to the top of the page
+Quote Post
AlexVallat
post Jan 16 2014, 19:50
Post #2462





Group: Developer
Posts: 1048
Joined: 31-July 06
Member No.: 33465



QUOTE (ChrisCTR @ Jan 16 2014, 15:51) *
Do an artist search for Tony Guerrero, and the album name "Now and Then".
[...] using an album cover result from LastFM.

Thanks, that's helpful. If you click the little (i) in the top right of the result, it will open the web page for the result. In this case, that is: Now and Then - Tony Guerrero. On that page you can see that the only image they have is the 130x130 thumbnail that they've grabbed off amazon, and if you check out the images page they simply don't have any.

So AAD has done the best it can from this source, and given you the only artwork they've made available for that album.

When the size is displayed in grey, it's an estimate based on either the size reported by the website, or sometimes just a guess based on what it usually provides, depending on the script author. They aren't always right - in this case, the 300x300 image expected simply wasn't there.

Alex
Go to the top of the page
+Quote Post
Eli
post Jan 23 2014, 01:56
Post #2463





Group: Members
Posts: 1055
Joined: 16-October 03
Member No.: 9337



Alex, any know bugs when scanning large libraries?

My workflow:
Open File Browser in AAD
select my library folder and click "search"

the number of albums seems to reach a max even though it keeps searching

however, I am now realizing that the returned results of the search are different from time to time (some albums appear that didn't before and some don't)

My library is quite large, 8000-9000 discs and about 90,000 tracks and over 2TB


--------------------
http://forum.dbpoweramp.com/showthread.php?t=21072
Go to the top of the page
+Quote Post
Eli
post Jan 23 2014, 17:01
Post #2464





Group: Members
Posts: 1055
Joined: 16-October 03
Member No.: 9337



Is there a way to filter by date or exclude albums from a search by date?

If the folder.jpg file has a certain date or newer, I would like to exclude it from search results


--------------------
http://forum.dbpoweramp.com/showthread.php?t=21072
Go to the top of the page
+Quote Post
AlexVallat
post Jan 23 2014, 20:06
Post #2465





Group: Developer
Posts: 1048
Joined: 31-July 06
Member No.: 33465



QUOTE (Eli @ Jan 23 2014, 01:56) *
Alex, any know bugs when scanning large libraries?
I don't know of any, but I haven't got a library of that size to test it against! In fact, I don't even have a disk of that size to test it against...

Are you sure you are using the same settings for searching each time? If you are using ID3 tags or path matching, then you would get different results for the same files.

You might also consider using Foobar2000 to manage your library, and then the Foobar browser instead of the File browser.

I'm afraid there is no easy way of excluding albums which have folder.jpg of a given date. I can't even think of a good difficult way of doing it, to be honest, sorry - all the album management tools I know of only care about the existence and contents of folder.jpg, not it's date. Your best bet would probably be to use Windows Explorer to search for folder.jpg, sort the results by date, then delete all the ones *older* than the required date. Then, once you've done the search, (ignoring all those which have results), you can restore the deleted files from the recycle bin. Pretty horrible, I know, but I can't think of anything better. It's not going to be a feature added to AAD.

Alex
Go to the top of the page
+Quote Post
Eli
post Jan 23 2014, 22:06
Post #2466





Group: Members
Posts: 1055
Joined: 16-October 03
Member No.: 9337



QUOTE (AlexVallat @ Jan 23 2014, 14:06) *
QUOTE (Eli @ Jan 23 2014, 01:56) *
Alex, any know bugs when scanning large libraries?
I don't know of any, but I haven't got a library of that size to test it against! In fact, I don't even have a disk of that size to test it against...

Are you sure you are using the same settings for searching each time? If you are using ID3 tags or path matching, then you would get different results for the same files.

You might also consider using Foobar2000 to manage your library, and then the Foobar browser instead of the File browser.

I'm afraid there is no easy way of excluding albums which have folder.jpg of a given date. I can't even think of a good difficult way of doing it, to be honest, sorry - all the album management tools I know of only care about the existence and contents of folder.jpg, not it's date. Your best bet would probably be to use Windows Explorer to search for folder.jpg, sort the results by date, then delete all the ones *older* than the required date. Then, once you've done the search, (ignoring all those which have results), you can restore the deleted files from the recycle bin. Pretty horrible, I know, but I can't think of anything better. It's not going to be a feature added to AAD.

Alex


Using path matching every time.

I tried with Foobar and Foobar browser in the past, but never quite got it to work right. I might try again.

My issue with the date is that I don't want to re-search for albums w/ AAD that I have recently updated the album art on. So a feature request would be to add a date filter to ignore results in the AAD search based on date stamps of folder.jpg


--------------------
http://forum.dbpoweramp.com/showthread.php?t=21072
Go to the top of the page
+Quote Post
SigHunter
post Jan 31 2014, 00:02
Post #2467





Group: Members
Posts: 40
Joined: 22-September 08
Member No.: 58544



Hi there,

I don't know if this has been reported in any of the hundreds of pages in this thread but this bug (?) annoys me since some years now:

it happens to about 1 in 100 albums when using the batch download "get album art for selection".
it sort of "mixes things up", shows the path of album "A" but downloads the cover and shows artist & album name of album "B"
which is also one of those 100 albums i'm searching a cover for.

here are some pics:




keep in mind that those are not false positives, AAD mixes something up here, although the albumtags are recognized correctly:




also, this basically never happens a second time,
when i delete this obviously wrong cover and rescan the directory and download the missing covers it gets it right

This post has been edited by SigHunter: Jan 31 2014, 00:05
Go to the top of the page
+Quote Post
AlexVallat
post Jan 31 2014, 09:39
Post #2468





Group: Developer
Posts: 1048
Joined: 31-July 06
Member No.: 33465



QUOTE (SigHunter @ Jan 31 2014, 00:02) *
it happens to about 1 in 100 albums when using the batch download "get album art for selection".
it sort of "mixes things up", shows the path of album "A" but downloads the cover and shows artist & album name of album "B"

Wow, that's really weird. No, I've not had that reported before.

So, let me see if I've got this straight: You use the File Browser to get a list of albums with missing artwork, then, with the "Automatically download and save the first result that meets set criteria" option selected, click "Get Artwork for Selection". That opens the "Get Artwork Automatically" window, where you have the sources and criteria set. One question - are you using only Discogs, or do you have multiple sources checked?

Then, after hitting Start, it does it's automatic downloading, but for some of the results it's used the wrong path for the wrong album despite being correct in the file browser window?

I'll have a go at reproducing that and see if I can come up with any fix.

Thanks for reporting it,

Alex
Go to the top of the page
+Quote Post
SigHunter
post Jan 31 2014, 09:52
Post #2469





Group: Members
Posts: 40
Joined: 22-September 08
Member No.: 58544



QUOTE (AlexVallat @ Jan 31 2014, 09:39) *
So, let me see if I've got this straight: You use the File Browser to get a list of albums with missing artwork, then, with the "Automatically download and save the first result that meets set criteria" option selected, click "Get Artwork for Selection". That opens the "Get Artwork Automatically" window, where you have the sources and criteria set.

Then, after hitting Start, it does it's automatic downloading, but for some of the results it's used the wrong path for the wrong album despite being correct in the file browser window?

Yes, that is exactly how it takes place

QUOTE (AlexVallat @ Jan 31 2014, 09:39) *
One question - are you using only Discogs, or do you have multiple sources checked?

discogs, encyclopaedia metallum and last.fm. discogs is set to "search first".
i'll screenshot every case that happens, maybe i'll find a pattern

QUOTE (AlexVallat @ Jan 31 2014, 09:39) *
Thanks for reporting it,

thanks for your work!
Go to the top of the page
+Quote Post
AlexVallat
post Jan 31 2014, 20:08
Post #2470





Group: Developer
Posts: 1048
Joined: 31-July 06
Member No.: 33465



QUOTE (SigHunter @ Jan 31 2014, 09:52) *
Well, I couldn't reproduce it, but I've done some general hardening around the multi-threading in that area, it might help. Could you give: AlbumArtDownloaderXUI-1.01-experimental.zip a quick go and see if it makes any difference?

If not, please also let me know what the "Specify path to find images" box in the File Browser options has in it.

Thanks,

Alex
Go to the top of the page
+Quote Post
SigHunter
post Jan 31 2014, 20:54
Post #2471





Group: Members
Posts: 40
Joined: 22-September 08
Member No.: 58544



QUOTE (AlexVallat @ Jan 31 2014, 20:08) *
QUOTE (SigHunter @ Jan 31 2014, 09:52) *
Well, I couldn't reproduce it, but I've done some general hardening around the multi-threading in that area, it might help. Could you give: AlbumArtDownloaderXUI-1.01-experimental.zip a quick go and see if it makes any difference?

If not, please also let me know what the "Specify path to find images" box in the File Browser options has in it.

Thanks,

Alex

thanks alot, i will test it this weekend

my settings should be pretty much default, i don't think i changed anything here:



Go to the top of the page
+Quote Post
SigHunter
post Feb 1 2014, 02:11
Post #2472





Group: Members
Posts: 40
Joined: 22-September 08
Member No.: 58544



seems to be a bit buggy:


for every cover it downloads

and no pictures appear in the folders

This post has been edited by SigHunter: Feb 1 2014, 02:11
Go to the top of the page
+Quote Post
AlexVallat
post Feb 1 2014, 08:57
Post #2473





Group: Developer
Posts: 1048
Joined: 31-July 06
Member No.: 33465



QUOTE (SigHunter @ Feb 1 2014, 02:11) *
no pictures appear in the folders
Sorry, I completely forgot to mention, I'd neutered the experimental version so it doesn't actually save them, it just adds them to the results list showing where they would have been saved. This is so that it's safe to run over the same results that produced the error, without worrying that it would overwrite your existing valid cover art!

If you'd rather test one which does save out the images, I've put one up here now: AlbumArtDownloaderXUI-1.01-experimental-2.zip

Alex
Go to the top of the page
+Quote Post
SigHunter
post Feb 2 2014, 23:06
Post #2474





Group: Members
Posts: 40
Joined: 22-September 08
Member No.: 58544



QUOTE (AlexVallat @ Feb 1 2014, 08:57) *
QUOTE (SigHunter @ Feb 1 2014, 02:11) *
no pictures appear in the folders
Sorry, I completely forgot to mention, I'd neutered the experimental version so it doesn't actually save them, it just adds them to the results list showing where they would have been saved. This is so that it's safe to run over the same results that produced the error, without worrying that it would overwrite your existing valid cover art!

If you'd rather test one which does save out the images, I've put one up here now: AlbumArtDownloaderXUI-1.01-experimental-2.zip

Alex


thanks, that's more what i was expecting biggrin.gif

done 'bout 350 covers in total today and yesterday, no switched paths seen so far,
i'll keep using this one to further test it, but it looks very promising, thanks!


since you mentioned multithreading, wouldn't it be possible (in a not that difficult manner) to handle
two albums at once in the batch downloader? (two should be enough for speedup purposes)

i mean, it is basically working through that list of albums, just spawn a second worker for another album that does the same thing as the first one

regards
Go to the top of the page
+Quote Post
AlexVallat
post Feb 3 2014, 09:08
Post #2475





Group: Developer
Posts: 1048
Joined: 31-July 06
Member No.: 33465



QUOTE (SigHunter @ Feb 2 2014, 23:06) *
wouldn't it be possible (in a not that difficult manner) to handle
two albums at once in the batch downloader? (two should be enough for speedup purposes)

Great, thanks for letting me know. I'll give it a few more days in case anything does pop up, then consider it fixed and release 1.01 with this fix in it.

For doing multiple albums at once, yes it would be technically possible, although not simple to do and prone to subtle errors (like the one you found!). Your best bet, really, if you want to do this, is to launch two automatic downloader windows. Select half your albums for one to find, and half for the other. You do run a higher risk of encountering throttling and other protections against mass downloading from the source websites though, depending on which ones you use.

Alex
Go to the top of the page
+Quote Post

101 Pages V  « < 97 98 99 100 101 >
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 20th April 2014 - 00:31