IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
iTunes + embedded album artwork: odd behaviours/any way to circumvent?, 1—It converts images to PNG first. 2—Embedding in AIFF sometimes fails
mwheelerk
post Dec 22 2011, 06:39
Post #1





Group: Members
Posts: 9
Joined: 11-October 09
From: Phoenix, AZ. USA
Member No.: 73896



I have a couple of issues relating to album artwork in iTunes.

I am always on the lookout for better quality artwork for my album covers. I have been of the habit of comparing a new cover with the one in iTunes. I do this by selecting a song within the album I am working with and Get Info>Artwork. I then drag the image from the artwork box to the desktop. I then use Preview on my Mac to compare the two image files. What I have begun to notice is that jpeg artwork files I originally embedded into iTunes are now much larger png files. In other words it appears iTunes is converting the files to png. Has anyone else noticed this? Does anyone know why this is occurring? Is there anyway to stop this conversion?

The next issue has to due with embedding artwork into AIFF files. It seems that this is a very hit and miss operation when using AIFF files. I would guess that 90% of the time the files embed properly. The other 10% will vary from the image not embedding on with any songs or embedding with some and not the others. On a Mac using Finder to find the album file prior to embedding the artwork each song file will have a small music note in gray with a white background. After embedding the artwork image appears next to the file as expected. When I have attempted to embed and for whatever reason it has not worked then the same musical note appears next to the song file name but now with a dark gray background. On the occassion when the artwork embeds with only some song files either that same musical note with gray background or a solid black box will appear. I then have to go through various gyrations to delete the gray/black images and try to re-embed the artwork or even to the point of converting the music files to ALAC then embed the artwork and then reconvert to AIFF. am I the only fool suffering with this nonsense? What's going on? What should I do?
Go to the top of the page
+Quote Post
mixminus1
post Dec 23 2011, 05:59
Post #2





Group: Members
Posts: 684
Joined: 23-February 05
Member No.: 20097



Can't help you with the AIFF issue, but as far as the PNG issue, see here:

http://www.hydrogenaudio.org/forums/index....showtopic=91889


--------------------
"Not sure what the question is, but the answer is probably no."
Go to the top of the page
+Quote Post
mwheelerk
post Dec 25 2011, 12:15
Post #3





Group: Members
Posts: 9
Joined: 11-October 09
From: Phoenix, AZ. USA
Member No.: 73896



My entire library had been Apple Lossless and I import CDs using iTunes. My library had been rock solid and I had virtually no issues. About a month ago for a couple of reasons I converted my entire library to AIFF. Now it is about 50/50 that I will have a problem with an AIFF file when trying to embed artwork and I am getting very frustrated. I have been looking at XLD and MAX as alternatives to iTunes but it seems the artwork issue remains with AIFF files there also. I am wondering with Apple Lossless becoming open source if I might be better off reconverting my library to Apple Lossless.

This post has been edited by db1989: Dec 25 2011, 14:05
Reason for edit: Please do not start a new thread when you have a perfectly suitable one already; merged.
Go to the top of the page
+Quote Post
SmashCan
post Dec 25 2011, 18:45
Post #4





Group: Members
Posts: 34
Joined: 12-February 09
Member No.: 66927



After figuring out the problem I sent an email to Doug at Doug's Scripts. He sent me an iTunes script that separates all of your music into two playlists: one with embedded JPGs and one with embedded PNGs. After running it I found more than 20 gb of AACs that had PNGs embedded (all originals were JPGs)—quite a waste of space.

All you can do is fix the old files and make sure you don't use the "get info" method from now on.
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 18th April 2014 - 07:40