IPB

Welcome Guest ( Log In | Register )

Some of my FLAC files do not show tags in Windows Explorer, [TOS #6: was “FLAC ID3 tag” in Lossless/Other Codecs]
OJNSim
post May 16 2013, 09:56
Post #1





Group: Members
Posts: 2
Joined: 16-May 13
Member No.: 108161



Hi

After ripping my CDs library, I have few Flac encoded songs which seems to have a tags issue.

In these songs Windows explorer can not display their ID3 tags. this also happen in my android phone, which prevent these songs from being played on the phone.
For some of the songs where I have managed to add the tags by using Mp3tag, and I now can play on the phone - but for some reason it didn't work for the rest.

To be clear - Mp3Tag displays the tags but Windows and the Android app Apollo seems to fail recognizing them.

All songs are being played perfectly in Windows.

Please advise

tx


Go to the top of the page
+Quote Post
 
Start new topic
Replies
db1989
post May 16 2013, 10:27
Post #2





Group: Super Moderator
Posts: 5141
Joined: 23-June 06
Member No.: 32180



Are these actually ID3 tags? I mean rather than using ID3 as a generic term to refer to any type of tag. If they are ID3, they should not be. From the official FAQ:
What kinds of tags does FLAC support?

FLAC has it's [sic] own native tagging system which is identical to that of Vorbis. They are called alternately "FLAC tags" and "Vorbis comments". It is the only tagging system required and guaranteed to be supported by FLAC implementations.

Out of convenience, the reference decoder knows how to skip ID3 tags so that they don't interfere with decoding. But you should not expect any tags beside FLAC tags to be supported in applications; some implementations may not even be able to decode a FLAC file with ID3 tags.

As you mentioned having used MP3tag, you might have considered telling us what type of tags it reports in your files.

Anyway, Windows Explorer does not natively support Vorbis comments. To display those, you would need to install a third-party extension. Perhaps the tracks whose tags you can see in Explorer have ID3 tags and the rest do not. Ideally, none of them should have ID3 tags.

Another piece of important information that might help describe the phenomenon and is missing:
QUOTE
After ripping my CDs library
With which program? Which settings?
Go to the top of the page
+Quote Post
OJNSim
post May 23 2013, 21:32
Post #3





Group: Members
Posts: 2
Joined: 16-May 13
Member No.: 108161



QUOTE (db1989 @ May 16 2013, 10:27) *
Are these actually ID3 tags? I mean rather than using ID3 as a generic term to refer to any type of tag. If they are ID3, they should not be. From the official FAQ:
QUOTE ( [url="http://flac.sourceforge.net/faq.html")
http://flac.sourceforge.net/faq.html[/url] ]What kinds of tags does FLAC support?

FLAC has it's [sic] own native tagging system which is identical to that of Vorbis. They are called alternately "FLAC tags" and "Vorbis comments". It is the only tagging system required and guaranteed to be supported by FLAC implementations.

Out of convenience, the reference decoder knows how to skip ID3 tags so that they don't interfere with decoding. But you should not expect any tags beside FLAC tags to be supported in applications; some implementations may not even be able to decode a FLAC file with ID3 tags.

As you mentioned having used MP3tag, you might have considered telling us what type of tags it reports in your files.

Anyway, Windows Explorer does not natively support Vorbis comments. To display those, you would need to install a third-party extension. Perhaps the tracks whose tags you can see in Explorer have ID3 tags and the rest do not. Ideally, none of them should have ID3 tags.

Another piece of important information that might help describe the phenomenon and is missing:
QUOTE
After ripping my CDs library
With which program? Which settings?


Sorry for the late response - I was not aware there is an answer - didnt get any mail

Problem solved - after reading the answer, I checked with Mp3Tag and the tags of the problematic songs where ID3V2 and not Flac tags i.e. Vorbis comment
I converted them to Flac, and now all good

tx


Go to the top of the page
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 16th April 2014 - 06:22