IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
OGMs don't work with megamix?
fragtal
post Jul 20 2004, 14:54
Post #1





Group: Members
Posts: 274
Joined: 1-January 03
From: Old Europe
Member No.: 4353



I am unable to make an ogm out of the Forrest Gump DVD. I ripped the Audio 5.1 AC3, transcoded it to WAV using AC3Decode, encoded it using Vorbis megamix I and vorbisgained it. Now Oggmux (0.9.4) says it can't open the ogg file.

So I reripped the Audio and did the same process again. But I used megamix II (again q2) this time. It still doesn't work.

I'm running windows XP pro SP1. Each time I open the directory (in which there is the ogg file) using the windows explorer it loads 400MB into my RAM (which is only 256MB, it gets up to 600 to 700MB.. sad.gif)

Did anyone observe the same problem?

best regards

Daniel


--------------------
I love the moderators.
Go to the top of the page
+Quote Post
Erbse
post Jul 20 2004, 17:21
Post #2





Group: Members
Posts: 13
Joined: 13-May 02
Member No.: 2038



I used Megamix 2 in my last ripp (AC3-> Ogg with Besweet/Oggmachine, muxing with Oggmux) no problems at all !! biggrin.gif
Go to the top of the page
+Quote Post
Atlantis
post Jul 20 2004, 21:48
Post #3





Group: Members
Posts: 250
Joined: 27-December 02
From: ROMA, Italy
Member No.: 4269



QUOTE (fragtal @ Jul 20 2004, 03:54 PM)
Now Oggmux (0.9.4) says it can't open the ogg file.
I'm running windows XP pro SP1. Each time I open the directory (in which there is the ogg file) using the windows explorer it loads 400MB into my RAM (which is only 256MB, it gets up to 600 to 700MB.. sad.gif)

Uhm... have you tried the latest version of oggmux?
Your version seems pretty old, the latest is 0.9.5.1.
You can also try reinstalling OggDS (0.9.9.5).

I use virtualdubmod to create ogm files, it never gave problems and works correctly with aotuvb2, megamix I and II.

smile.gif

This post has been edited by Atlantis: Jul 20 2004, 22:09


--------------------
Vital papers will demonstrate their vitality by spontaneously moving from where you left them to where you can't find them.
Go to the top of the page
+Quote Post
fragtal
post Jul 20 2004, 23:26
Post #4





Group: Members
Posts: 274
Joined: 1-January 03
From: Old Europe
Member No.: 4353



@Atlantis

I just tried it with Virtual Dub Mod and it worked fine. Thanks. Long live OGM! smile.gifsmile.gif


--------------------
I love the moderators.
Go to the top of the page
+Quote Post
Peter
post Jul 21 2004, 01:00
Post #5





Group: Admin
Posts: 3269
Joined: 30-September 01
Member No.: 84



Offtopic matroska zealot posts moved here.


--------------------
This job would be great if it wasn't for the users.
Go to the top of the page
+Quote Post
jcsston
post Jul 21 2004, 02:42
Post #6





Group: Members
Posts: 54
Joined: 15-May 03
From: Texas
Member No.: 6622



QUOTE (zZzZzZz @ Jul 20 2004, 04:00 PM)
Offtopic matroska zealot posts moved here.
*

Off-topic as in trying to help users that are using unsupported software?


--------------------
Official Matroska Tag B0rker.
MatroskaProp http://cdl.matroska.org/
Go to the top of the page
+Quote Post
Peter
post Jul 21 2004, 02:46
Post #7





Group: Admin
Posts: 3269
Joined: 30-September 01
Member No.: 84



QUOTE (jcsston @ Jul 21 2004, 04:42 AM)
QUOTE (zZzZzZz @ Jul 20 2004, 04:00 PM)
Offtopic matroska zealot posts moved here.
*

Off-topic as in trying to help users that are using unsupported software?
*


Help ? I see only attempts to convince him to use different format rather than help with OGM in posts removed. If you want to demonstrate why MKV/AVI/whatever is superior to OGM, start a separate topic instead of trolling topics where people ask tech questions and want them answered.
This is my final warning. Next offtopic post here will result in admin actions.


--------------------
This job would be great if it wasn't for the users.
Go to the top of the page
+Quote Post
Bonzi
post Jul 21 2004, 05:13
Post #8


A/V Moderator


Group: Members
Posts: 278
Joined: 22-February 03
Member No.: 5132



QUOTE (Atlantis @ Jul 20 2004, 12:48 PM)
Uhm... have you tried the latest version of oggmux?
Your version seems pretty old, the latest is 0.9.5.1.
You can also try reinstalling OggDS (0.9.9.5).

I use virtualdubmod to create ogm files, it never gave problems and works correctly with aotuvb2, megamix I and II.

smile.gif
*


Actually, that is fine. I would recommend 0.9.5.1 over 0.9.9.5. The ones with a newer version number actually were from an older branch of OggDs. These newer ones don't seem to work as well anyway. What I would recommend you do for playback is to use MPC because it has a built in OGG splitter and then use CoreVorbis to playback the vorbis audio. That way you can use CoreVorbis to play vorbis audio from other containers too without problems from OGGDs. IIRC there was some problems with other containers ie matroska accepting the audio fast enough to decode from the directshow parser, this is one of the major things CoreVorbis fixes. Although if you are just using OGM you don't have to bother.

I used to use vdubmod to create my OGM files ~ 2 years ago since then I haven't really used OGM much. However, if you are sick of directshow/vfw muxing then you might want to try out this http://cyrius.bunkus.org/ogmtools.html these tools are based on Mosu's ogmtools and are usually highly recommended by people that use OGM as their container of choice.

Honestly though, your problems with the explorer taking up soo much memory sound more like directshow problems. Sounds to me like it wants to preview the first frame in the avi to display in explorer. Others have had the same problem http://forum.doom9.org/showthread.php?s=&threadid=57637 and the fix http://forum.doom9.org/showthread.php?s=&threadid=18050 the fix is for AVI but it doesn't matter IIRC because shmedia.dll "gets file attributes, or even views thumbnails" in general I think.
EDIT: The problem is with the ogg file and not the OGM though isn't it? Oh well, I think the fix should still be the same.
Go to the top of the page
+Quote Post
robUx4
post Jul 21 2004, 09:26
Post #9


Matroska Developer


Group: Developer (Donating)
Posts: 410
Joined: 14-March 02
From: Paris
Member No.: 1519



Since the other thread is closed (!) I'll reply here.

I think it's helping people to let them know OGM is not a good option for anything. Every ppl who worked on it left it for good. But users still have habits. And often we assume it's because they don't know there are better alternatives.

Now if you want to play admins, first move this thread in Digital A/V-Container Formats...


--------------------
http://www.matroska.org/ : the best vapourware / http://robux4.blogspot.com/
Go to the top of the page
+Quote Post
Pamel
post Jul 21 2004, 09:55
Post #10





Group: Members
Posts: 147
Joined: 15-June 03
Member No.: 7199



QUOTE (Bonzi @ Jul 20 2004, 11:13 PM)
However, if you are sick of directshow/vfw muxing then you might want to try out this http://cyrius.bunkus.org/ogmtools.html these tools are based on Mosu's ogmtools and are usually highly recommended by people that use OGM as their container of choice.
Both major Matroska devs...

Cyrius more recently rewrote a lot of his OGM code because he didn't like code that bad floating around with his name on it. If applicable, get the files from here.

Also, there are some DirectShow filters being developed by Illiminable that are supposed to have OGM reading built in. I don't know if that part of the code works yet, but it is planned. Note that this is reading only, not writing. Xiph is rather opposed to the idea of people creating more OGMs.

Seriously though, you may want to consider moving to Matroska. It has much lower overhead for many configurations, it is actively supported, and it has existing specifications. Whenever the majority of a format's developers recommend using a different format, it might be a good idea to switch.
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 24th April 2014 - 06:18