IPB

Welcome Guest ( Log In | Register )

> foobar2000 Tech Support Forum Rules

Please read foobar2000 Tech Support Forum Rules before posting and comply with all the points.
Failure to provide all the information pointed out in the above document in your post is considered wasting other people's time and in extreme cases will lead to your topic getting locked without a reply.


See also: Hydrogenaudio Terms of Service.

E-MU 0404 USB - foobar2000 "forgets" ASIO config on shutdown
andy_c
post Mar 25 2008, 18:08
Post #1





Group: Members
Posts: 61
Joined: 3-June 07
Member No.: 44031



Hi,

I've been having a problem with Foobar 0.9.5 "forgetting" the ASIO config for my E-MU 0404 USB sound device when I shut down the system. I'm using the E-MU as a USB-to-S/PDIF converter to drive an external DAC. For whatever reason, S/PDIF only works with the E-MU 0404 USB when ASIO is used.

When I go into the ASIO virtual device editor, it looks like this initially:

ANALOG OUT 32-bit Left
ANALOG OUT 32-bit Right
S/PDIF OUT 32-bit <none>
S/PDIF OUT 32-bit <none>

I then change it to:

ANALOG OUT 32-bit <none>
ANALOG OUT 32-bit <none>
S/PDIF OUT 32-bit Left
S/PDIF OUT 32-bit Right

Then, in "output device" I choose "ASIO: ASIO E-MU 0404 | USB", and click the "Save All" button. This works fine, just as expected. I can play all supported files just fine.

Next, I reboot and try to use Foobar with this saved ASIO configuration. When I try to play a file, I get the message "Unrecoverable playback error: Requested ASIO driver not found". To fix this, I must go into the ASIO virtual device config and choose "Remove" for the displayed E-MU 0404 USB. Before removal, the text of the device name is still shown, but the driver is somehow not recognized. Next, I add the configuration back in using the "Add New" button, then re-do the configuration process as I've described above, assigning Left and Right to the two S/PDIF logical outputs. Once I do this, my files play just fine again. However, this means I must go through this procedure each time I run Foobar from a freshly-rebooted system.

Any help with this would be greatly appreciated!

This post has been edited by andy_c: Mar 25 2008, 23:40
Go to the top of the page
+Quote Post

Posts in this topic
- andy_c   E-MU 0404 USB - foobar2000 "forgets" ASIO config on shutdown   Mar 25 2008, 18:08
- - andy_c   I just wanted to add that I just now saw that 0.9....   Mar 25 2008, 18:34
- - Canar   Error 0404: device not found?   Mar 25 2008, 20:02
- - volvme+   My 0404 usb also lose its ASIO settings after rebo...   Mar 26 2008, 18:51
|- - andy_c   QUOTE (volvme+ @ Mar 26 2008, 11:51)...   Mar 27 2008, 01:32
- - bubbleguuum   Same problem here, this is very annoying and proba...   Apr 21 2008, 14:53
- - nightfishing   known issue with all 0.9x versions + Emu 0404   Apr 22 2008, 03:43
- - Peter   The driver re-registers itself with a different cl...   Apr 22 2008, 10:47
|- - bubbleguuum   QUOTE (Peter @ Apr 22 2008, 11:47) The dr...   Apr 22 2008, 12:55
|- - andy_c   QUOTE (Peter @ Apr 22 2008, 03:47) The dr...   Apr 28 2008, 16:00
- - volvme+   Somebody should mail e-mu and report back what the...   Apr 22 2008, 13:16
- - Peter   The whole point of CLSIDs is being able to identif...   Apr 28 2008, 16:30
|- - andy_c   QUOTE (Peter @ Apr 28 2008, 09:30) The wh...   Apr 28 2008, 18:47
- - Peter   The ASIO specification says that if you have multi...   Apr 28 2008, 20:24
- - volvme+   QUOTE Kristian, Our support for audio players is ...   Apr 28 2008, 21:16
|- - yayacek   The problem still exist. Is there any chance to so...   Jun 29 2008, 14:25
|- - mchaka   I was thinking that maybe somebody could make a ...   Aug 27 2008, 21:54
|- - fanerman91   So, is there a quick fix for this? Not-so-quick f...   Oct 19 2008, 23:22
|- - Fred de Nantes   QUOTE (fanerman91 @ Oct 19 2008, 23:22) S...   Nov 21 2008, 23:33
|- - George K   In my experience ASIO4All is not an adequate subst...   Nov 22 2008, 02:52
- - Kohlrabi   I have the same problem with a Creative Audigy 4 i...   Dec 12 2008, 20:36
- - leeperry   sorry to bump an old thread....but is this problem...   May 2 2009, 05:36
|- - a3aan   Yes. QUOTE (leeperry @ May 2 2009, 05:36...   May 2 2009, 10:39
|- - yayacek   Please explain! The old Foobar 0.8.3 keeps ASI...   Jan 25 2010, 15:29
- - Yirkha   The driver can be trivially hacked to use the same...   Jan 27 2010, 13:18
|- - yayacek   QUOTE (Yirkha @ Jan 27 2010, 06:18) The d...   Jan 27 2010, 22:53
- - Canar   Just use DirectSound. The DS drivers behave as you...   Jan 27 2010, 14:00
|- - yayacek   QUOTE (Canar @ Jan 27 2010, 07:00) Just u...   Jan 27 2010, 22:49
|- - Canar   QUOTE (yayacek @ Jan 27 2010, 16:49) With...   Jan 28 2010, 00:42
- - Yirkha   You can see the relevant part of the log here.   Jan 28 2010, 00:43
|- - needle   QUOTE (Yirkha @ Jan 27 2010, 15:43) You c...   May 22 2010, 09:54
- - ZenZendra   Yirkha, so have you been successful? And if you ha...   Sep 24 2010, 22:37
- - Yirkha   Well I don't own E-MU 404 card, so I personall...   Sep 25 2010, 05:41
- - ZenZendra   I have found emasio.dll in system32, so if you can...   Sep 25 2010, 14:16
- - Yirkha   OK, got it fine. What OS are you running, Windows ...   Sep 25 2010, 14:55
- - ZenZendra   I' m running 7   Sep 25 2010, 16:33
- - Yirkha   OK, then the solution might be amazingly simple. ...   Sep 25 2010, 16:46
- - ZenZendra   It doesn't work every time i restart my compu...   Sep 25 2010, 17:17
- - Yirkha   Hmm how exectly did you try it, step by step? It m...   Sep 25 2010, 17:36
- - ZenZendra   Ok, i started the whole procedure again. I returne...   Sep 25 2010, 17:49
- - Yirkha   All right. Sorry for the previous confusion and th...   Sep 30 2010, 01:12
- - ZenZendra   I'm sorry for the delayed answer, but it was w...   Oct 2 2010, 17:28
- - Yirkha   That's great news! You are welcome, I...   Oct 3 2010, 17:51
|- - intruder.outsider   QUOTE (Yirkha @ Oct 3 2010, 17:51) That...   Oct 14 2010, 19:46
- - Kiyos   I'm on Windows 7 x64, and I guess my card uses...   Oct 14 2010, 22:05
- - Yirkha   Bah, I've thought it will be neccessary to han...   Oct 17 2010, 23:28
- - Yirkha   OK, I've modified the x64 version too - see th...   Oct 18 2010, 02:35
- - T_B_Good   Hello, Yirkha I am running Win 7 64bit, E-mu 0202 ...   Oct 18 2010, 09:12
|- - Yirkha   QUOTE (T_B_Good @ Oct 18 2010, 10:12) I a...   Oct 18 2010, 12:10
- - T_B_Good   Thank you for reply. Ok. For the clarity of the e...   Oct 18 2010, 13:07
- - T_B_Good   Yirkha, thank you it works finally!!! ...   Oct 18 2010, 14:10
- - Yirkha   Awesome! I was already thinking what I had pos...   Oct 18 2010, 14:14
- - T_B_Good   You are great! It would be nice to hear a feed...   Oct 18 2010, 14:21
- - Kiyos   Yirkha, thank you for all the trouble! Guess t...   Oct 18 2010, 21:40
- - T_B_Good   Kiyos, I suspect that turning on/off is not equal ...   Oct 19 2010, 11:34
- - Yirkha   You are right that all 32-bit applications use onl...   Oct 19 2010, 13:48
- - Kiyos   Here's some further feedback. After replacing ...   Oct 19 2010, 22:17
- - Yirkha   Please do share, sounds like I screwed something u...   Oct 19 2010, 23:43
- - a3aan   Nice stuff. EMU just released new (beta) drivers. ...   Oct 20 2010, 09:25
- - Yirkha   QUOTE (Kiyos @ Oct 19 2010, 23:17) After ...   Oct 20 2010, 15:26
- - faau   new beta driver for win7 haven't solve this pr...   Oct 21 2010, 04:47
- - Yirkha   Well, I assume they have already stated somewhere ...   Oct 21 2010, 14:59
- - Kiyos   At least there's hope for steady Windows 7 sup...   Oct 21 2010, 15:11
- - Kiyos   Sorry, the previous post was irrelevant I've ...   Oct 21 2010, 22:57
- - Yirkha   No problem, of course you are free to comment on a...   Oct 22 2010, 11:07
- - Kiyos   Further tests have proved that the new libs work a...   Oct 23 2010, 22:59
- - Axel555   Yirkha: Thanks a lot for your patched EMU ASIO dri...   Oct 26 2010, 17:50
- - yeahyeah2002   I just brought 0404usb about 2 month and annoying ...   Oct 30 2010, 04:43
- - Petru   Thank you Yirkha!!! You made this worl...   Nov 12 2010, 00:58
- - yayacek   Does it work on Windows XP?   Nov 16 2010, 01:11
- - Yirkha   Yes, sure.   Nov 16 2010, 14:06
|- - yayacek   QUOTE (Yirkha @ Nov 16 2010, 07:06) Yes, ...   Nov 16 2010, 16:03
- - rkay5   Hi, I'm using e-mu 0404 usb os w7 64bit. To...   Jan 18 2011, 01:38
- - yip2133   To Yirkha Many thanks to you. My foobar now works...   Feb 5 2011, 17:40
- - sauron_pk   Yirkha you are great men!! Can you please...   Mar 6 2011, 04:49
- - (((STEREO)))   Yirkha - Can't thank you enough for addressing...   Mar 23 2011, 16:34
- - Marco89   Is there the similar patch for E-MU 0204? Because ...   Mar 29 2011, 18:58
- - sauron_pk   QUOTE (sauron_pk @ Mar 6 2011, 04:49) Yir...   Apr 5 2011, 14:54
- - sauron_pk   up   Apr 27 2011, 00:42
- - FreeBorN   The owner of an EMU-0404 is thanking Yirkha for hi...   Jun 18 2011, 20:36
- - hmoewou   Thank you very very much Yirkha! I'm usin...   Jun 26 2011, 16:03
- - T_B_Good   Marco89, this solution works for E-MU 0204 as well...   Oct 29 2011, 15:21
- - AudioOmen   Any news about the problem guys? I've recentl...   Nov 28 2011, 11:16


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 20th April 2014 - 03:04