IPB

Welcome Guest ( Log In | Register )

> foobar2000 Tech Support Forum Rules

Please read foobar2000 Tech Support Forum Rules before posting and comply with all the points.
Failure to provide all the information pointed out in the above document in your post is considered wasting other people's time and in extreme cases will lead to your topic getting locked without a reply.


See also: Hydrogenaudio Terms of Service.

 
Reply to this topicStart new topic
No playback of Ogg files encoded by Reaper
Dandruff
post Aug 14 2008, 08:26
Post #1





Group: Members
Posts: 491
Joined: 20-April 04
Member No.: 13618



Playback of Ogg files rendered by Reaper doesn't work in Foobar2000 (0.9.5.5)!



Foobar2000:

View -> Console: "Decoding failure at 0:00.000 (Unsupported format or corrupted file)"



I've tried many different encoding settings but none of them worked. Reaper itself can decode the file(s). Any ideas?


FIXED (Reaper 2.45pre3)


http://forum.cockos.com/showthread.php?t=24770

This post has been edited by Dandruff: Aug 16 2008, 09:14
Go to the top of the page
+Quote Post
Synthetic Soul
post Aug 14 2008, 09:01
Post #2





Group: Super Moderator
Posts: 4887
Joined: 12-August 04
From: Exeter, UK
Member No.: 16217



VideoLan doesn't like it much either. It will play it, but it thinks that it is 3 seconds long and 499kb/s. It also has weird clicks and pauses when played. As part of the Messages output, it also reports:

ogg warning: couldn't find any ogg logical stream

MPC recognises it as 10 seconds as per foobar, and appears to play it OK - that is if the clicks and pauses are supposed to be there (which it seems like maybe they are now).


--------------------
I'm on a horse.
Go to the top of the page
+Quote Post
Dandruff
post Aug 14 2008, 09:14
Post #3





Group: Members
Posts: 491
Joined: 20-April 04
Member No.: 13618



QUOTE (Synthetic Soul @ Aug 14 2008, 10:01) *
that is if the clicks and pauses are supposed to be there


Yes, they are.


I also can confirm your findings. VLC plays it but is reporting wrong duration. Only Media Player Classic seems to do the job "properly" ...


FIXED (Reaper 2.45pre3)

This post has been edited by Dandruff: Aug 16 2008, 09:15
Go to the top of the page
+Quote Post
kjoonlee
post Aug 14 2008, 09:48
Post #4





Group: Members
Posts: 2526
Joined: 25-July 02
From: South Korea
Member No.: 2782



Buggy encoder.
CODE
Processing file "reaper.ogg"...

New logical stream (#1, serial: 00152eca): type vorbis
Vorbis headers parsed for stream 1, information follows...
Version: 0
Vendor: Xiph.Org libVorbis I 20050304 (1.1.1)
Channels: 2
Rate: 48000

Nominal bitrate: 499.821000 kb/s
Upper bitrate not set
Lower bitrate not set
Negative or zero granulepos (0) on vorbis stream outside of headers. This file was created by a buggy encoder
Vorbis stream 1:
    Total data length: 198155 bytes
    Playback length: 0m:10.173s
    Average bitrate: 155.818600 kb/s
Logical stream 1 ended


Testing was done with ogginfo. BTW, running it through vorbiscomment fixed it.

Both ogginfo and vorbiscomment for Windows can be downloaded at RareWares.

http://www.rarewares.org/ogg-tools.php


--------------------
http://blacksun.ivyro.net/vorbis/vorbisfaq.htm
Go to the top of the page
+Quote Post
Dandruff
post Aug 14 2008, 19:25
Post #5





Group: Members
Posts: 491
Joined: 20-April 04
Member No.: 13618



@kjoonlee: thanks for testing this! hope it will help the reaper developers ...
Go to the top of the page
+Quote Post
jarsonic
post Aug 15 2008, 20:34
Post #6





Group: Members
Posts: 196
Joined: 30-September 01
From: C-ville, VA
Member No.: 83



I think Justin's going to fix it in the next release of Reaper; he's aware of it now.
Go to the top of the page
+Quote Post
Dandruff
post Aug 15 2008, 20:51
Post #7





Group: Members
Posts: 491
Joined: 20-April 04
Member No.: 13618



Cool, thanks!
Go to the top of the page
+Quote Post
Dandruff
post Aug 16 2008, 09:19
Post #8





Group: Members
Posts: 491
Joined: 20-April 04
Member No.: 13618



FIXED in Reaper 2.45pre3 cool.gif

http://www.landoleet.org
Go to the top of the page
+Quote Post
seaeye
post Aug 21 2008, 22:00
Post #9





Group: Members
Posts: 64
Joined: 3-October 01
Member No.: 181



QUOTE (kjoonlee @ Aug 14 2008, 09:48) *
BTW, running it through vorbiscomment fixed it.


hey - can you give more details about running them "through" vorbiscomment? i haven't found any option to remove / rewrite comments, but probably i'm looking at a wrong place.
thanks in advance.

a
Go to the top of the page
+Quote Post
kjoonlee
post Sep 7 2008, 13:49
Post #10





Group: Members
Posts: 2526
Joined: 25-July 02
From: South Korea
Member No.: 2782



Oh. I just added a random comment with vorbiscomment.


--------------------
http://blacksun.ivyro.net/vorbis/vorbisfaq.htm
Go to the top of the page
+Quote Post
seaeye
post Sep 7 2008, 18:25
Post #11





Group: Members
Posts: 64
Joined: 3-October 01
Member No.: 181



that made the trick! thank you!
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd April 2014 - 18:44