IPB

Welcome Guest ( Log In | Register )

foo_midi glitches
yuriks
post Dec 17 2008, 14:24
Post #1





Group: Members
Posts: 6
Joined: 11-September 08
Member No.: 58135



Hey,

I've recently installed the foo_midi component, and got myself SynthFont VST version as a synth engine and "65.8mg music man gm gs v1.0 bank" as the soundfont. It works nicely, but when starting a new song (either by directly selecting it on the playlist or skipping track forward or backwards) I get a period of intense slowdown while the audio glitches a lot producing loud noise sounds. This doesn't happen when I let a midi end and then the next one play automatically.

Is that a problem with foo_midi, SynthFont, my soundfont or my midis?
Go to the top of the page
+Quote Post
 
Start new topic
Replies (1 - 2)
yuriks
post Dec 25 2008, 06:13
Post #2





Group: Members
Posts: 6
Joined: 11-September 08
Member No.: 58135



Just solved my own problem, check "EMIDI device track exclusion (Duke3D, etc.)" in the foo_midi configuration tab. Incidentally, I was playing the Duke Nukem 3D soundtrack. wink.gif
Go to the top of the page
+Quote Post
kode54
post Dec 25 2008, 08:31
Post #3





Group: Admin
Posts: 4504
Joined: 15-December 02
Member No.: 4082



Maybe it doesn't like the duplicate note events that are otherwise filtered out by that option? (And maybe I should have made that feature hard-coded, since it's really important to eliminate the alternate FM synth tracks from some of the songs, and unlikely to encounter any false positives in other MIDI files.)
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 24th April 2014 - 19:25