IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
Libvorbis 1.3.1 released!
NullC
post Mar 26 2010, 14:09
Post #1





Group: Developer
Posts: 200
Joined: 8-July 03
Member No.: 7653




Libvorbis 1.3.1 has been released.
The primary improvement in this version is encoder support for coupled surround sound (the decoder always supported it).
More information about the surround development work can be found here and here.

The release also includes a few minor psy-behaviour improvements, but I don't expect them to be ABXable. PQevalaudio likes them however and for -q0 on my 48khz mono test set it shows an average ODG improvement of .0217. (I use PQevalaudio as part of a larger testing infrastructure, and as a quick "is anything broken" test. I don't expect it to be especially right about psy-behaviour) Most of that improvement comes from a single file with a score increase of 0.1 from libvorbis 1.2.3. So if anyone is planning on doing a -q0 comparison with 1.2.3 that might be a useful file to include, but I'd recommend saving the listening tests for a subsequent release.

One of the more substantial of psy changes was removed from the release at the last moment because there was some concern that it might be causing regressions and that the changes hadn't been adequately tested. The next cycle of AoTuV merge work will be in a subsequent release— this one was focused on bug-fixes and surround.

libvorbis improvements:

- Optimized/coupled surround support for 5.1 encoding at 44.1/48kHz
- Added encoder control call to disable channel coupling
- Corrected an overflow bug in very low-bitrate encoding on 32 bit
machines that caused inflated bitrates
- Numerous API hardening, leak and build fixes
- Correct bug in 22kHz compand setup that could cause a crash
- Correct bug in 16kHz codebooks that could cause unstable pure
tones at high bitrates

Along with libvorbis a number of other related packages have been released:

libao improvements:

- AO returned to active development
- Added surround channel mapping API and capability
- Updated all drivers on modern installs
- New config file options
- Driver options may be specified in config file
- Support for MacOSX updated to 10.5 and later
- Build in WMM driver rather than using dlopen()
- Added Roar Audio driver
- Added OpenBSD SNDIO driver
- Workaround for ESD non-4096 byte write bug
- Workaround aRts server crash bug
- Workaround for VIA82xx click/crackle bugs under ALSA
- Remove dead/unused drivers (solaris, alasa05, mmsound)
- Numerous patches from multiple downstreams

vorbis-tools improvements:

vorbis-tools 1.4.0 is the first official release of vorbis-tools since
1.2.x. 1.3.x was never offered as an official snapshot, though
various versions were widely deployed as patch-sets by distributions.

- Implement corrected channel mappings for all input and playback file types
- Correct an possible infinite loop in WAV input reading code when header is corrupt
- Implement "disable_coupling" option for oggenc
- Fix Ctrl-C lockup bug in ogg123
- ogg123 directory playback in sorted order
- Add WAVEFORMATEXTENSIBLE support
- More translations
- Add '-' as stdin/out filename in vcut
- Add -lnetwork check for socket in configure
- Remove 'extra' F parameter from ogg123 remote output
- Numerous code and build fixes

Changes in the new libogg release include:

- A new default flushing behavior that reduces overhead for moderate
and high bitrate streams, such as video
- Documentation updates
- Various build fixes intended to keep the autofoo and Windows build
mechanisms up to date
- Build fixes for additional compilers
This release is ABI and API compatible with previous incarnations of libogg.

Tarballs and zipfiles of the official release can be found in the
usual place at http://downloads.xiph.org/releases/


Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 16th April 2014 - 23:59