IPB

Welcome Guest ( Log In | Register )

Windows Media Player and Windows Explorer won't read some ID3v2.3
rajkumari
post May 7 2011, 21:05
Post #1





Group: Members
Posts: 3
Joined: 7-May 11
From: Rio de Janeiro
Member No.: 90441



I had posted this on another forum, but they couldn't help me there no matter how much they tried (this problem is kind of weird), so they told me to ask for help here. I'll try to describe my problem in detail here, as well as talk about what was already suggested to me and didn't work.

I had hundreds of tagged MP3 files on my old notebook (which broke a few days ago), whose tags showed correctly both on iTunes and on Windows Media Player. I bought a new computer recently and, when I transferred the files from the old to the new one, most of the tags were gone. Well, they're still being shown on iTunes, which means my ID3v2.4 tags are safe, and if I open them on Mp3tag it'll show all the correct tags, and it'll say they're ID3v2.3, which means that, in thesis, Windows Media Player and Windows Explorer should have no trouble reading them, but most songs have absolutely no info on both. There doesn't seem to be a pattern as to which files' tags can and can't be read; some are fine and some gone, for no apparent reason. If I try to add tags using Windows Media Player, they're correct for a few seconds, but then they're back to being blank. I can't edit tags using the Details tab on the Properties menu of the files; when I click on the tag I want to edit, instead of a text box appearing, nothing happens; I just can't type. This happens on both the tagless files and the OK ones. It's as if the files were read only, but they're not. I'm not getting error messages nor anything like that; I just can't change tags. I've also tried saving the tags on Mp3tag, but nothing happens. I mean, if I make any changes, they do show on Mp3tag itself, but the tags are still wrong (or nowhere to be seen) on Windows Explorer and Windows Media Player.

Also, there's an odd detail: when I opened the contents of the external HD my old computers' songs are in using Windows Explorer on that old computer itself, the files would all be OK; if I open them on the new one, they'd be wrong.

I think I know how this mess started: a few weeks ago, I was trying to find a way of making Devnagri (a non-Unicode script) song and album titles and artist names show correctly on iTunes. I Google it, and got to a website that had rather confuse instructions. It looked like the site was telling me to change the ID3 version of the files. As I had no idea what that was by then (see? There's always a bright side: all this crap has at least taught me something about MP3 file tagging! Yeah, thank you, Lord, though I still think you could've found a better way to teach me about that), I thought it could do no harm, and selected all files (why, oh, why all? Couldn't I have tested it with only ONE?), right-clicked, selected "Convert ID3 Tags..." and changed the ID3 version lots of times. I think I tried all available versions, and none did what I wanted it to (i.e., make Devnagri text not show as little squares). The problem started when I converted the tags to ID3v1.0; since it has a character limit, all tags that were longer than X characters were partially lost and I spent a few hours retying everything (do I even need to comment on how pissed off I was? This should teach me to test first, THEN risk my whole music folder). So, perhaps that caused this issue; I mean, before that happened, I had successfully transferred MP3 files from my old computer to other ones (including this very same one) with no tag problem, and also, the MP3 files I downloaded AFTER all that happened have all their info correct, and their tags CAN be edited using the Properties thing on Windows Explorer. However, why only some files of the files that had they tags messed up that day, and not all of them, lost their tags, is beyond my knowledge. And since I can't use that old laptop any more, I can't restore that computer to an earlier date and try to get the "unmessed up" versions of the files, so I MUST find a way to fix the files I currently have, unless I have to redownload everything - which would be nearly impossible, as I have 300+ broken MP3s.

Could anyone please, please, please help me? crying.gif

ETA: If this helps, here are the files on Mp3tag; here you can see the very same files on Windows Explorer, and here, on iTunes.

This post has been edited by rajkumari: May 7 2011, 21:34
Go to the top of the page
+Quote Post
 
Start new topic
Replies
2thumbs
post May 8 2011, 00:55
Post #2





Group: Members
Posts: 39
Joined: 27-January 04
Member No.: 11565



Hrmm. It is possible that the files ended up with chained ID3 tags? In other words, an ID3v2.3 tag followed by an ID3v2.4 tag? This could explain some of the behaviour you're seeing. You can check for this by opening the file in a hex editor and looking for the sequence 0x49 0x44 0x33. This will be followed by the version bytes, 0x03 0x00 for 2.3, 0x04 0x00 for 2.4 respectively. Generally these will appear before the first MPEG frame. If you find more than one of these, you ended up with chained tags.

Since you already have MP3Tag installed, you can also test for this by going into the options and telling MP3Tag to remove ID3v2 tags (tools -> options -> tags, check "remove ID3v2"). If you then right-click on one of your files and select "remove tag", you should see the ID3v2.3 tag disappear and the 2.4 return. If that's not the case, something else is going on. This works because MP3Tag only "sees" the first ID3v2 tag and ignores anything after. So if you remove it, MP3Tag will then "see" the 2.4 tag. Obviously any kind of potentially destructive editing should be done on copies or test files.

If you've added your music to the "Music" folder in Windows, it's possible that WMP will scan these files for artist info and album art. In this case it will continue to modify files only tagged using ID3v2.4.

This post has been edited by 2thumbs: May 8 2011, 01:01
Go to the top of the page
+Quote Post
rajkumari
post May 8 2011, 02:17
Post #3





Group: Members
Posts: 3
Joined: 7-May 11
From: Rio de Janeiro
Member No.: 90441



OMG, thank you, thank you, thank you! biggrin.gif Now I can add info manually! biggrin.gif I couldn't get the right info back, but I had already lost my hopes of ever seeing those tags again; at least I can re-add everything now. I'm so happy! Seriously, you don't know how much you've helped me! I have OCD, and not having tags was driving me completely crazy. I never thought I'd ever say this, but I can't wait for tomorrow afternoon, when I'll retype everything. biggrin.gif Thanks a lot, one more time!
Go to the top of the page
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 18th April 2014 - 12:47