IPB

Welcome Guest ( Log In | Register )

> foobar2000 Tech Support Forum Rules

Please read foobar2000 Tech Support Forum Rules before posting and comply with all the points.
Failure to provide all the information pointed out in the above document in your post is considered wasting other people's time and in extreme cases will lead to your topic getting locked without a reply.


See also: Hydrogenaudio Terms of Service.

 
Reply to this topicStart new topic
Unrecoverable playback error: Audio data format not supported by this , 6 channel, 48000 Hz, 24 bit. Virtual Audio Cable.
Magus
post Oct 20 2011, 03:46
Post #1





Group: Members
Posts: 5
Joined: 13-May 06
Member No.: 30724



UPDATE: sorry, I did notice there was a tech support forum, but ended up forgetting to post this topic in there. Will a moderator please move it? sad.gif

Hello. I was a bit skeptical about posting about this issue here, as it also involves a useful 3rd-party software named Virtual Audio Cable (version 4.10) that creates virtual audio devices (virtual cables that let you mix different audio streams so they can, for instance, be captured in a recording), but since Foobar is the only program that actually presented problems with it, I decided to do it. I use Windows 7 64-bit.

If Windows considers the virtual audio device to be 2-channel, 48000 Hz, 24 bit, Foobar works fine. In the Virtual Audio Cable Control Panel, all virtual cable devices are set in a way they support 5.1 channels (in fact, even more, since I'm having this issue and, thus, messed around with VAC), so this isn't the cause of the issue - I can even test the speakers in the 5.1 setup individually by testing the virtual device. However, even though the music I listen to though Foobar is stereo, I don't like being restricted to stereo rather than 5.1 (say, for games), so I go to Control Panel -> Sound, and under Playback, find the audio device and open its properties. Then I go to Advanced, Default Format and set it to 6-channel, 48000 Hz, 24 bit (my sound card - a Sound Blaster X-Fi Platinum - supports this - the corresponding audio device in Windows is configured for this too).





When I try playing music in Foobar with the virtual device as the output device, the following error happens:


Unrecoverable playback error: Audio data format not supported by this device (0x88780064)

I wonder if the audio format is being misinformed by Windows. Manually specifying the output format the way it used to be in Foobar might be helpful for investigating this, but I'm not aware of how to do it now that Foobar automatically detects the supposedly appropriate output format.

VLC, Media Player Classic and the Adobe Flash Player plug-in in Firefox and Chrome play audio normally though the virtual device (it's set as default), so this feels like an annoying bug in Foobar.

Will you please take a look at this?

Thanks! smile.gif

This post has been edited by Magus: Oct 20 2011, 03:56
Go to the top of the page
+Quote Post
shakey_snake
post Oct 20 2011, 06:17
Post #2





Group: FB2K Moderator
Posts: 4322
Joined: 1-November 06
From: Cincinnati
Member No.: 37036



Are you using DirectSound for output or a separate output component?

QUOTE (Magus @ Oct 19 2011, 22:46) *
Manually specifying the output format the way it used to be in Foobar might be helpful for investigating this, but I'm not aware of how to do it now that Foobar automatically detects the supposedly appropriate output format.


You can use a x channel to x channel DSP in your fb2k DSP chain and the resampler DSP to force output format.

This post has been edited by shakey_snake: Oct 20 2011, 06:24


--------------------
elevatorladylevitateme
Go to the top of the page
+Quote Post
Magus
post Oct 20 2011, 16:49
Post #3





Group: Members
Posts: 5
Joined: 13-May 06
Member No.: 30724



Hmmm. By using the "Convert stereo to 4 channels" DSP, it works if the audio device is set to be 4-channel (and this doesn't work without the DSP smile.gif), but not 6-channel. Is there a "convert stereo to 5.1" DSP? Now we know the automatic format detection isn't perfect, at least with Virtual Audio Cable. It isn't right for there to be a need for this format forcing, is it?



I'm not using a separate output component, so I believe it's DirectSound.
Go to the top of the page
+Quote Post
kode54
post Oct 20 2011, 16:52
Post #4





Group: Admin
Posts: 4504
Joined: 15-December 02
Member No.: 4082



In Windows Vista and newer, the DirectSound output driver forces 32-bit floating point format. You can force enable the integer formats by forcing XP compatibility mode, but then you lose random neat things like the Vista file browser dialogs which actually have no theoretical file count limit and such.
Go to the top of the page
+Quote Post
Magus
post Oct 20 2011, 17:07
Post #5





Group: Members
Posts: 5
Joined: 13-May 06
Member No.: 30724



I tried allowing up to 32 bits on the device (VAC Line 1), but it didn't make a difference. sad.gif



Windows XP compatibility mode did not make it work either. I tried manually specifying 16-bit and 24-bit in the Foobar output preferences while in this mode.
Go to the top of the page
+Quote Post
lvqcl
post Oct 20 2011, 17:21
Post #6





Group: Developer
Posts: 3214
Joined: 2-December 07
Member No.: 49183



QUOTE
Is there a "convert stereo to 5.1" DSP?

foo_channel_mixer, foo_dsp_fsurround_beta, foo_dsp_mm, foo_dsp_upmix, and maybe more.
Go to the top of the page
+Quote Post
kode54
post Oct 20 2011, 19:03
Post #7





Group: Admin
Posts: 4504
Joined: 15-December 02
Member No.: 4082



Maybe it doesn't like WAVEFORMATEXTENSIBLE.
Go to the top of the page
+Quote Post
bsw11
post Oct 27 2011, 00:32
Post #8





Group: Members
Posts: 128
Joined: 19-April 09
From: Los Angeles CA
Member No.: 69081



Something you might try is using the WASAPI driver interface and lowering your buffer size or just lowering the buffer size on the current interface for that matter. See my other post - that is what fixed my problem. No clue why :-).
Go to the top of the page
+Quote Post
Magus
post Nov 8 2011, 13:01
Post #9





Group: Members
Posts: 5
Joined: 13-May 06
Member No.: 30724



Hi. Sorry for the delay. If I force a 6-channel output via DSP - I'm using Channel Mixer (foo_channel_mixer) - it works. If I tell it to output less channels (even 5), it doesn't.

I read bsw11's suggestion and at first tried only changing the buffer length. Even a 50-ms buffer didn't make a difference when I picked Virtual Audio Cable 1 without a channel-changing DSP, but kept using the default output component... Then I switched to the WASAPI one and it worked. However, does anyone know why WASAPI is modifying the number of channels to 6 even without a DSP? I hear sound from the central speaker while listening to stereo music with no DSP! ohmy.gif In fact, if I force 2 channels via Channel Mixer, I still do!

Also, any cons about using WASAPI? I imagine there is a reason why it is not the preferrable audio output method...

Thanks!

This post has been edited by Magus: Nov 8 2011, 13:06
Go to the top of the page
+Quote Post
Magus
post Nov 9 2011, 23:06
Post #10





Group: Members
Posts: 5
Joined: 13-May 06
Member No.: 30724



UPDATE: WASAPI causes either overflows or underflows after some time, depending on the buffer size set in Foobar, resulting in either audio corruption or silence. I imagine it's related to the "exclusive" nature of the device allocation. DirectSound has not caused this so far.
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st April 2014 - 06:23