IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
Error when embedding EAC extraction log in flac file using metaflac, "File <file>.log for 'eaclog' tag value has embedded
rohangc
post Nov 1 2011, 16:08
Post #1





Group: Members
Posts: 569
Joined: 1-December 02
From: India
Member No.: 3948



Hi. I just ripped an extremely old CD into a single file FLAC image + CUE sheet. When I try to embed the EAC extraction log file into the image, I get the following error:

CODE
C:\Users\Me\Desktop>metaflac.exe --set-tag-from-file="eaclog=1.log" 1.flac
1.flac: ERROR: file '1.log' for 'eaclog' tag value has embedded NULs


I am able to embed other files such as the CUE sheet into the 'cuesheet' block using the same command without any problems.

I have seen REACT2 embed EAC log files into the 'eaclog' block without any problems before, so I don't understand why this operation fails when executed separately on the command line.

For the record, I use Windows 7 64-bit and I am logged in as the administrator.

Please help me embed the file into the said metadata block.
Go to the top of the page
+Quote Post
rohangc
post Nov 4 2011, 05:00
Post #2





Group: Members
Posts: 569
Joined: 1-December 02
From: India
Member No.: 3948



Silly me!! I just used FB2K to embed the metadata.

Wonder why I didn't think of it earlier rolleyes.gif
Go to the top of the page
+Quote Post
db1989
post Nov 4 2011, 11:10
Post #3





Group: Super Moderator
Posts: 5157
Joined: 23-June 06
Member No.: 32180



Still, I wonder why the log had a NUL in it?
Go to the top of the page
+Quote Post
lvqcl
post Nov 4 2011, 11:15
Post #4





Group: Developer
Posts: 3212
Joined: 2-December 07
Member No.: 49183



QUOTE (greynol @ Dec 12 2010, 00:46) *
QUOTE (Xenion @ Dec 11 2010, 10:14) *
why are logs now in unicode?

To satisfy continual requests by people who I would assume need unicode in order to properly title their albums.
Go to the top of the page
+Quote Post
db1989
post Nov 4 2011, 11:16
Post #5





Group: Super Moderator
Posts: 5157
Joined: 23-June 06
Member No.: 32180



Oh, so metaflac doesn’t support Unicode; thanks for the explanation.
Go to the top of the page
+Quote Post
nu774
post Nov 4 2011, 12:10
Post #6





Group: Developer
Posts: 476
Joined: 22-November 10
From: Japan
Member No.: 85902



metaflac apparently supports Unicode. metaflac uses UTF-8 for tagging;
UTF-8 is one of Unicode byte representations, which is ASCII compatible and far more preferable than UTF-16LE as a text encoding.
It's just that metaflac doesn't support UTF-16LE as external text encoding by any means.

metaflac assumes locale charset (or codepage in Windows) as external text encoding (command line args, and text files) by default.
When --no-utf8-convert option is specified, it assumes UTF-8 is used, and doesn't do any character encoding conversion.
However, no UTF-16LE.

So, in this case, the following will work:
  1. Convert UTF-16LE encoded EAC log to UTF-8 (notepad can be used in Windows).
  2. Then, pass metaflac the UTF-8 encoded log with --no-utf8-convert specified.

Go to the top of the page
+Quote Post
gism
post Mar 14 2013, 19:00
Post #7





Group: Members
Posts: 42
Joined: 6-January 10
Member No.: 76763



QUOTE (nu774 @ Nov 4 2011, 12:10) *
metaflac apparently supports Unicode. metaflac uses UTF-8 for tagging;
UTF-8 is one of Unicode byte representations, which is ASCII compatible and far more preferable than UTF-16LE as a text encoding.
It's just that metaflac doesn't support UTF-16LE as external text encoding by any means.

metaflac assumes locale charset (or codepage in Windows) as external text encoding (command line args, and text files) by default.
When --no-utf8-convert option is specified, it assumes UTF-8 is used, and doesn't do any character encoding conversion.
However, no UTF-16LE.

So, in this case, the following will work:
  1. Convert UTF-16LE encoded EAC log to UTF-8 (notepad can be used in Windows).
  2. Then, pass metaflac the UTF-8 encoded log with --no-utf8-convert specified.


I tried --no-utf8-convert with --set-tag=FIELD and doesn't work. How can Unicode tags be set with metaflac?
Go to the top of the page
+Quote Post
gism
post Mar 14 2013, 20:47
Post #8





Group: Members
Posts: 42
Joined: 6-January 10
Member No.: 76763



^ Got it to work by using --set-tag-from-file=FIELD
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 20th April 2014 - 12:26