IPB

Welcome Guest ( Log In | Register )

MPC and EAC don't work with command lines options
LaurentNerva
post Jan 18 2012, 13:16
Post #1





Group: Members
Posts: 9
Joined: 18-January 12
From: France
Member No.: 96531



Hello.

I would like ripping and encoding WAV to MPC with the extern programm mpcenc.exe but there is a malfunction. The settings are here :



With this setup in Additional command-line options :

CODE
--quality 9 --xlevel --ape2 --artist "%a" --title "%t" --album "%g" --year "%y" --track "%n" --genre "%m" %s

I have this error message :



Even this only setting don't works :

CODE
--quality 9

How can I do ?

Thanks...
Go to the top of the page
+Quote Post
 
Start new topic
Replies
db1989
post Jan 18 2012, 21:27
Post #2





Group: Super Moderator
Posts: 5147
Joined: 23-June 06
Member No.: 32180



Edit: Ignore what I said before.

You would need to include %dest% in your command-line for mppenc.exe, i.e. before the double-ampersand (denoting a new command)—however, EAC maps %source% and %dest% to temporary file-names that it then renames afterwards, so this will probably not work. Perhaps you could work around this by pasting your file-naming syntax in place of %dest%. Also, you may want/need to enclose both %source% and %dest% within double-quotes in order to avoid the encoder choking on otherwise-ambiguous spaces in the command-line. Son of Edit: Seems I was wrong (probably EAC only does this in certain cases, whereas I misremembered that it applied all the time), so please see the below post by lvqcl.

For placeholders, see also: http://wiki.hydrogenaudio.org/index.php?ti...AC_placeholders

This post has been edited by db1989: Jan 18 2012, 21:51
Go to the top of the page
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 19th April 2014 - 06:38