IPB

Welcome Guest ( Log In | Register )

Sennheiser RS120—volume knob causes static/dropouts in 1 ear (2 pairs), [TOS #6: was "Sennheiser RS 120 problems"]
shepard
post Apr 23 2012, 02:31
Post #1





Group: Members
Posts: 30
Joined: 29-October 05
Member No.: 25434



I bought my first pair of these 4, maybe 5? years ago. I only use them to watch TV and really like them. After a couple of years the volume knob started not working properly. I hardly ever use it as I set the volume once and for most TV it is fine. Once in a rare while I will adjust them a little. What happened is that the adjustment would cause static or cutting out in one ear when turned. I figured I had them for 2 or 3 years, I would just replace them. I did and all is OK for a couple of new years with the new set. But just this week they started doing the same thing.

Is this something common with these? Seems like a loose connection or something. I searched and saw a thread here about another brand doing something similar and the suggestion was to "clean" them. Does that make any sense?

Thanks!
Go to the top of the page
+Quote Post
 
Start new topic
Replies
shepard
post Apr 23 2012, 14:13
Post #2





Group: Members
Posts: 30
Joined: 29-October 05
Member No.: 25434



But I expect the 160's cost more and if this is a problem common to the Sennheiser turning knobs then what's the point of buying an even more expensive pair? Do those have a different type of volume control?

Yes the noise when turning is not the issue, it is that it cuts out at certain points so only one ear works. Then you have only a limited few spots you can listen at and often those are not the correct volume locations.
Go to the top of the page
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 20th April 2014 - 20:05