IPB

Welcome Guest ( Log In | Register )

> foobar2000 Tech Support Forum Rules

Please read foobar2000 Tech Support Forum Rules before posting and comply with all the points.
Failure to provide all the information pointed out in the above document in your post is considered wasting other people's time and in extreme cases will lead to your topic getting locked without a reply.


See also: Hydrogenaudio Terms of Service.

 
Reply to this topicStart new topic
Metadata erasing itself
fishman550
post Aug 3 2012, 00:23
Post #1





Group: Members
Posts: 2
Joined: 3-August 12
Member No.: 101969



Recently every time I play a song in foobar, as soon as the song finishes all the metadata gets erased on its own and the song just shows up in foobar as the file name.

Is this a known bug that will be fixed or what?

It's really annoying as now I have half my songs with no metadata and half with and manually re-doing the title, artist, album for so many songs will take hours.

Thanks for any help.
Go to the top of the page
+Quote Post
neothe0ne
post Aug 3 2012, 02:53
Post #2





Group: Members
Posts: 294
Joined: 25-September 05
Member No.: 24684



No, this isn't a known bug. I'd suggest making your files read-only, then performing a "test" by seeing what complains about not being able to write to your music file.
Go to the top of the page
+Quote Post
db1989
post Aug 3 2012, 04:10
Post #3





Group: Super Moderator
Posts: 5159
Joined: 23-June 06
Member No.: 32180



As per the rules of this subforum, you might have thought to provide any background information, such as: the format/filetype, what type of tags the files have initially and once you’ve re-added them (with foobar2000 itself, I assume), any additional components that you are using, etc.

Edit: oh, also, whether you have Windows Media Player installed/active.

This post has been edited by db1989: Aug 3 2012, 04:11
Go to the top of the page
+Quote Post
fishman550
post Aug 3 2012, 10:36
Post #4





Group: Members
Posts: 2
Joined: 3-August 12
Member No.: 101969



They're all mp3, I applied all the tags myself a while back. I don't have windows media player at all I completely deleted the directory when I reinstalled windows.
Go to the top of the page
+Quote Post
BenB
post Aug 3 2012, 13:54
Post #5





Group: Members
Posts: 627
Joined: 17-April 12
Member No.: 98921



What version of foobar are you using? What components are installed (esp. any that write to your files' tags)? Are you using any "skins"? And what version are your id3 tags? What program originally wrote the tags to your files?

Are you absolutely positive that the tags are gone? Did you try reloading the metadata from the files or rescanning your library with foobar? Did you look at the tags in an external tag editor/viewer such as Mp3tag or Axone to verify? (Just because foobar isn't seeing them doesn't mean they aren't there).

Anyone else have access to your music library? If yes, might they have listened to your files with a different player?

This post has been edited by BenB: Aug 3 2012, 13:57
Go to the top of the page
+Quote Post
q-stankovic
post Aug 3 2012, 17:43
Post #6





Group: Members
Posts: 1718
Joined: 28-May 06
From: Düsseldorf
Member No.: 31251



The link db1989 shows a well known behaviour of wmp: on tag change the txxx-frames are messed up and parts of the header become the value of the frame. What fishman50 described is not a known bug in wmp as far as i know. The same happened to me too a half year ago: i remarked that about 300 tracks lost all its tags. Because foobar2000 still told that tag type is id3v2.3 i looked with a tag examiner and discovered that in allo the files were two PRIV-frames. I am not sure but i think in most, if not all cases complete albums were destroyed. The folders were indexed and placed in windows library. I can insure that the files weren't touched by windows explorer, wmp or windows media center. (all the files were tagged inside foobar with discogs component and manually)

This post has been edited by q-stankovic: Aug 3 2012, 17:43


--------------------
german support forum: www.foobar-users.de / user: qwert73
Go to the top of the page
+Quote Post
neothe0ne
post Aug 4 2012, 05:59
Post #7





Group: Members
Posts: 294
Joined: 25-September 05
Member No.: 24684



QUOTE (q-stankovic @ Aug 3 2012, 12:43) *
The same happened to me too a half year ago: i remarked that about 300 tracks lost all its tags. Because foobar2000 still told that tag type is id3v2.3 i looked with a tag examiner and discovered that in allo the files were two PRIV-frames. I am not sure but i think in most, if not all cases complete albums were destroyed. The folders were indexed and placed in windows library. I can insure that the files weren't touched by windows explorer, wmp or windows media center. (all the files were tagged inside foobar with discogs component and manually)


Well then, I'm sure glad I've been rolling with m4a for years... so yeah, I'd recommend setting mp3 files to read-only then. If you use mp3tag on those files, it will give you a prompt to turn off the read-only so it can save... but foobar would just deny the tag changes.

On a somewhat related note, in my experience having foobar2000 monitor the library in real-time is a bad thing for Mp3tag, which will then frequently fail to rename a file back from xxxxxx.tmp to track.mp3 or whatever whenever foobar2000 is running.
Go to the top of the page
+Quote Post
q-stankovic
post Aug 4 2012, 10:36
Post #8





Group: Members
Posts: 1718
Joined: 28-May 06
From: Düsseldorf
Member No.: 31251



QUOTE (neothe0ne @ Aug 4 2012, 06:59) *
Well then, I'm sure glad I've been rolling with m4a for years... so yeah, I'd recommend setting mp3 files to read-only then.

Well, i am more interested to know the reason for that rather than lock my files for tag editing. Does anybody know if placing music folder in a windows 7 library could lead to tag loss even if wmp, wmc and explorer weren't use for tagging or playing?


--------------------
german support forum: www.foobar-users.de / user: qwert73
Go to the top of the page
+Quote Post
db1989
post Aug 4 2012, 12:34
Post #9





Group: Super Moderator
Posts: 5159
Joined: 23-June 06
Member No.: 32180



I also agree that one should not have to make one’s files read-only and thereby lose the ability to deliberately alter them for oneself. Rather, one should not have to worry about outside agents doing things without explicit instruction/permission! At the very least, the program/OS should be so kind as to provide an option (however buried rolleyes.gif) to disable such behaviour. If it does not, I feel discussion should focus on finding ways to circumvent its design flaws, rather than telling the user they’re inevitable and that their circumvention mandates that s/he sacrifice desirable functionality.

However, the OP stated in post #4 that WMP has been removed from the equation, at least if deleting its directory is sufficient prevention. Therefore, the remaining options are (1) Windows itself and/or some leftover component of WMP is responsible, in which case the above discussion might lead somewhere; or (2) the cause lies elsewhere, in which case there is still a need for more information, and quite a bit of it, as BenB indicated.

This post has been edited by db1989: Aug 4 2012, 12:36
Go to the top of the page
+Quote Post
q-stankovic
post Aug 4 2012, 13:06
Post #10





Group: Members
Posts: 1718
Joined: 28-May 06
From: Düsseldorf
Member No.: 31251



Ok, it is a good advice to use only axone.jar for examaning tags! And sorry for giving false informations! I was lucky to find in some old backups a copy of an album that was destroyed and took a look with axcone.jar and not Heliums Music Manager's own tool. The ID3v2.4 tags are still in the files (like described in db1989's link).

The question is now how that could happen and how that empty ID3v2.3 area could be stripped. I assume using the tools in foobar2000 and mp3tag will copy the empty content of id3v2.3 to id3v2.4.


Edit
For the case that foobar2000's version number should be of importance: i always use the latest versions including betas and the relevant files were last modified on 19th january 2012

This post has been edited by q-stankovic: Aug 4 2012, 13:17


--------------------
german support forum: www.foobar-users.de / user: qwert73
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 20th April 2014 - 17:43