IPB

Welcome Guest ( Log In | Register )

EAC and flac
tidende
post Dec 3 2012, 09:46
Post #1





Group: Members
Posts: 7
Joined: 3-December 12
Member No.: 104944



Hi,

I have tried ripping and compressing CD's with EAC 1.0 beta 3 and have them compressed to flac. Unfortunately, I only get the wav-file, the cue-sheet and the txt-file. There does not seem to be anything wrong with the additional command line options: -8 -V -T "ARTIST=%artist%" -T "TITLE=%title%" -T "ALBUM=%albumtitle%" -T "DATE=%year%" -T "TRACKNUMBER=%tracknr%" -T "GENRE=%genre%" -T "COMMENT=%comment%" -T "BAND=%albuminterpret%" -T "ALBUMARTIST=%albuminterpret%" -T "COMPOSER=%composer%" %haslyrics%--tag-from-file=LYRICS="%lyricsfile%"%haslyrics% -T "DISCNUMBER=%cdnumber%" -T "TOTALDISCS=%totalcds%" -T "TOTALTRACKS=%numtracks%" %hascover%--picture="%coverfile%"%hascover% %source% -o %dest%. At least I am not warned of any errors when I test the encoder.

Thanks a lot

Go to the top of the page
+Quote Post
 
Start new topic
Replies
tidende
post Dec 3 2012, 21:17
Post #2





Group: Members
Posts: 7
Joined: 3-December 12
Member No.: 104944



I have tried all the suggestions. Nothing works. So I guess the problem does not have anything to do with the command line.
Go to the top of the page
+Quote Post
BFG
post Dec 4 2012, 00:09
Post #3





Group: Members
Posts: 205
Joined: 22-July 12
Member No.: 101637



QUOTE (tidende @ Dec 3 2012, 14:17) *
I have tried all the suggestions. Nothing works. So I guess the problem does not have anything to do with the command line.


If Manlord's suggested -5 %source% command didn't work, then the problem is indeed something else.
Are you sure you followed the blowfish guide exactly? Even something as simple as forgetting the . before "flac" in the file extension field could cause the encoder to fail.
(By the way, I disagree with the guide's recommendation to disable C2 error checking...but that's a different subject.)

If, on the other hand, Manlord's suggested commandline does work, AND the more complex commandline works when you Test the Encoder but not in practice, then the problem is almost certainly the %haslyrics% or %hascover% sections.
There is also the possibility that FLAC doesn't like the destination folder you're trying to write to, in which case FLAC would launch, but abort and fail to save any file. This is particularly true if you're on a Windows Vista or newer machine and are trying to save in a Program Files (or similarly "protected") folder. The only way to bypass that is to save to a different folder, or force FLAC always to launch at Administrative level.

EDIT: You might post screenshots of your Compression and EAC tabs. We could look for other, seemingly innocuous problems that way.

This post has been edited by BFG: Dec 4 2012, 00:12
Go to the top of the page
+Quote Post

Posts in this topic
- tidende   EAC and flac   Dec 3 2012, 09:46
- - Apesbrain   On the same tab where you set commandline options ...   Dec 3 2012, 15:20
|- - BFG   The EAC tester won't test the lyrics or album ...   Dec 3 2012, 15:38
|- - BFG   Too bad I can't edit my previous post anymore....   Dec 3 2012, 18:17
- - tidende   Thanks for the answers. To Apesbrain: Yes, I have...   Dec 3 2012, 18:32
|- - BFG   QUOTE (tidende @ Dec 3 2012, 11:32) To BF...   Dec 3 2012, 18:38
- - Manlord   I would start with a very simple set of options, l...   Dec 3 2012, 18:49
- - Surfi   :: Why not configure the FLAC command line with E...   Dec 3 2012, 20:20
- - tidende   I have tried all the suggestions. Nothing works. S...   Dec 3 2012, 21:17
|- - Surfi   :: ... posting a .log-file might be helpful ... ...   Dec 3 2012, 21:43
|- - BFG   QUOTE (tidende @ Dec 3 2012, 14:17) I hav...   Dec 4 2012, 00:09
|- - BFG   OK, now that I'm back home, I'll post the ...   Dec 4 2012, 01:47
- - JJZolx   QUOTE (tidende @ Dec 3 2012, 02:46) There...   Dec 3 2012, 22:29
- - greynol   -o %dest% is not necessary   Dec 3 2012, 22:51
- - tidende   EDIT of previously posted post. Ok, I think we a...   Dec 4 2012, 19:28
- - tidende   Tried to set the destination folder to C:\. T...   Dec 5 2012, 08:48
|- - BFG   QUOTE (tidende @ Dec 5 2012, 01:48) stuff...   Dec 5 2012, 23:29
- - naturfreak   Hint: If you do copy and paste the additional comm...   Dec 5 2012, 23:39
- - tidende   It appears that the problem was related to the des...   Dec 7 2012, 00:26
|- - JJZolx   QUOTE (tidende @ Dec 6 2012, 17:26) It ap...   Dec 7 2012, 03:43
||- - BFG   QUOTE (JJZolx @ Dec 6 2012, 20:43) Just g...   Dec 7 2012, 05:42
|- - Surfi   QUOTE (tidende @ Dec 7 2012, 00:26) I wou...   Dec 7 2012, 09:20
- - tidende   I was away for a few days. Thanks again for the su...   Dec 11 2012, 22:17


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 18th April 2014 - 14:55