IPB

Welcome Guest ( Log In | Register )

> foobar2000 Development Forum Rules

This forum is for developer discussions only. If you have a problem / bug report / idea / feature request that isn't related to foobar2000 SDK, post it in an appropiate forum instead - tech support questions go to support forum, everything else goes to general forum.
All non-developer posts on this forum will be removed. Continued abuse of this forum will result in admin actions (warnings, account suspension).

How does a plugin tell its version information?
skink
post Feb 28 2013, 23:18
Post #1





Group: Members
Posts: 4
Joined: 28-February 13
Member No.: 106950



Hey!

Today I've managed to write something that doesn't crash the player in C. It was all cool and fun to do that, but I still can't call it a plugin yet. I'm getting a popup message saying

QUOTE
Failed to load DLL: foo_test.dll
Reason: No version information found.


I found the DECLARE_COMPONENT_VERSION macro which declares a class named componentversion_myimpl and a variable called g_componentversion_myimpl_factory. But do I need to pass them to the player? How do I tell it the plugin's version and stuff?

Cheers!
Go to the top of the page
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 18th April 2014 - 17:36